A bug in Microsoft Store is preventing to use Start - I already tried all the most popular "fixes"

Dario de Judicibus 6 Reputation points
2021-01-18T08:52:44.547+00:00

I am really discouraged. I just bought a Dell G5 with Windows 10 to replace my old Lenovo because the operating system had become too unstable. I installed Office, Adobe Creative Cloud and Norton Antivirus and everything worked fine for a while. At one point Windows Update told me there were updates to install. I did, I rebooted the system and the ordeal began. The problem is well known, judging by how many people on the net claim to have it: the culprit is the Microsoft Store. There are three symptoms: 1. If I click on Microsoft Store, the window opens for a second and then disappears 2. if I click with the RMB on Explorer on the taskbar, taskbar’s jump list does not appear 3. if I click on Start, nothing happens Especially points 2. and 3. are a problem. So I started studying all the various solutions, but none of them worked. a. I launched "sfc /scannow": it works, there are no errors, but it does not fix the problem b. I launched "dism.exe /Online /Cleanup-image /RestoreHealth": it works, but it does not fix the problem c. I created another user: the problem occurred ALSO for the newly created user d. I used powershell to recreate the APPs: it reinstalled most apps, with few errors for few apps because the existing app had higher version or was in use Get-AppXPackage-AllUsers|Foreach{Add-AppxPackage-DisableDevelopmentMode-register"$($_InstallLocation.)\AppXManifest.xml"}: it does not fix the problem e. I launched "wsreset.exe": I got error ms-windows-store:PurgeCaches - app did not start I also tried several other strategies I found on Microsoft sites and forums (for example, permissions). No result. So I used the Media Creation Tool to get the latest version of Windows reinstalled from scratch. It was a mess because it gave me ONLY the option to loose all apps and files, but I did it. From a newly installed Windows 10, I started the whole process again. Now the Microsoft Store was ok, as well as Start and the taskbar’s jump list. I reinstalled the same applications than before, very standard, common and famous applications, the same I had on my old PC, but again, after a couple of restarts, I got the same problem. I am really upset. The whole architecture of Start based on Microsoft Store is obviously weak and unstable. I have no idea what to do now. I do not want to reinstall for the third time Windows 10. I need a REAL SOLUTION, once forever. Maybe troubleshooting by Event Manager, but not the usual try & hope!

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,834 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Jenny Yan-MSFT 9,326 Reputation points
    2021-01-19T06:21:16.263+00:00

    Hi,
    To better support your problem, kindly confirm following details:
    1.Was start button not working only when left click on it or even right click to call out following functions?
    57994-image.png

    1. If the former one, please confirm the OS version by type winver in the Run box.

    3.Have you successfully installed patches that mentioned? Please run get hotfix command to verify if the latest patches have been installed for your windows 10 version.
    Get-HotFix
    https://learn.microsoft.com/en-us/powershell/module/microsoft.powershell.management/get-hotfix?view=powershell-7.1

    4.Please also check if any errors have been recorded in following log file:%windir%\Logs\CBS\CBS.log file
    https://learn.microsoft.com/en-us/troubleshoot/windows-server/deployment/cbs-log-file-record-entries-not-repaired-run-sfc

    5.When you failed to open start button, please right click task bar and open task manager, navigate to windows explorer to restart.
    57898-image.png


    Hope this helps and please help to accept as Answer if the response is useful.

    Thanks,
    Jenny

    0 comments No comments

  2. Dario de Judicibus 6 Reputation points
    2021-01-19T14:29:32.637+00:00
    1. Former. The Start menu does no appear, as well as FeedbackApp, the notification sidebar on right side of screen, and other apps. Version is 20H2, build 19042.746.
    2. See below
    3. No error in %windir%\Logs\CBS\CBS.log, just Info
    4. Restarting Explorer makes no difference

    Please note that I applied a lot of technbique to fix the problem, with no success. SFC gives no error. I also reinstalled Windows from scratch and for few hours the Store button was back. Then it disappeared again.

    Source Description HotFixID InstalledBy InstalledOn


    DARIO-DELL Update KB4586876 NT AUTHORITY\SYSTEM 13/01/2021 00:00:00
    DARIO-DELL Update KB4562830 NT AUTHORITY\SYSTEM 10/12/2020 00:00:00
    DARIO-DELL Security Update KB4570334 27/09/2020 00:00:00
    DARIO-DELL Security Update KB4577266 09/10/2020 00:00:00
    DARIO-DELL Security Update KB4580325 09/10/2020 00:00:00
    DARIO-DELL Security Update KB4586864 NT AUTHORITY\SYSTEM 10/11/2020 00:00:00
    DARIO-DELL Security Update KB4593175 NT AUTHORITY\SYSTEM 09/12/2020 00:00:00
    DARIO-DELL Security Update KB4598481 NT AUTHORITY\SYSTEM 13/01/2021 00:00:00
    DARIO-DELL Security Update KB4598242 NT AUTHORITY\SYSTEM 13/01/2021 00:00:00

    Let me show you some og the typican messages I get in the Event Viewer (I show just few, but they occurs for mostly any app)

    This si just an example: do not focus on the specific app

    SearchApp.exe
    10.0.19041.546
    c404ae05
    KERNELBASE.dll
    10.0.19041.662
    ec58f015
    c0000409
    000000000010bd5c
    70c4
    01d6ee6eb9620fe8
    C:\Windows\SystemApps\Microsoft.Windows.Search_cw5n1h2txyewy\SearchApp.exe
    C:\WINDOWS\System32\KERNELBASE.dll
    ea48c7e6-0d52-401d-ba74-db69412db33b
    Microsoft.Windows.Search_1.14.0.19041_neutral_neutral_cw5n1h2txyewy
    CortanaUI

    or

    Fault bucket 1243035655595417406, type 5
    Event Name: MoBEX
    Response: Not available
    Cab Id: 0

    Problem signature:
    P1: Microsoft.Windows.Search_1.14.0.19041_neutral_neutral_cw5n1h2txyewy
    P2: praid:CortanaUI
    P3: 10.0.19041.546
    P4: c404ae05
    P5: KERNELBASE.dll
    P6: 10.0.19041.662
    P7: ec58f015
    P8: 000000000010bd5c
    P9: c0000409
    P10: 0000000000000007

    or

    Faulting application name: ShellExperienceHost.exe, version: 10.0.19041.610, time stamp: 0x5d4af3f4
    Faulting module name: KERNELBASE.dll, version: 10.0.19041.662, time stamp: 0xec58f015
    Exception code: 0xc0000409
    Fault offset: 0x000000000010bd5c
    Faulting process id: 0x44d4
    Faulting application start time: 0x01d6ee6e0690a7bb
    Faulting application path: C:\WINDOWS\SystemApps\ShellExperienceHost_cw5n1h2txyewy\ShellExperienceHost.exe
    Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
    Report Id: c99abf8f-e6c0-49e4-a727-e240fb961e1e
    Faulting package full name: Microsoft.Windows.ShellExperienceHost_10.0.19041.610_neutral_neutral_cw5n1h2txyewy
    Faulting package-relative application ID: App

    I also tried to reinstall the Store from

    Microsoft.NET.Native.Framework.2.2_2.2.29512.0_x64__8wekyb3d8bbwe.Appx
    Microsoft.NET.Native.Runtime.2.2_2.2.28604.0_x64__8wekyb3d8bbwe.Appx
    Microsoft.VCLibs.140.00_14.0.29231.0_x64__8wekyb3d8bbwe.Appx
    Microsoft.WindowsStore_12010.1001.313.0_neutral___8wekyb3d8bbwe.AppxBundle

    but I get an error trying to install any of them:

    X D:\Install\System\Store\Microsoft....Appx The app didn't start.

    0 comments No comments