Following latest Windows Store RDP client update, no longer able to connect to some servers.

Squibb, Stuart 76 Reputation points
2021-01-18T10:16:00.63+00:00

My Windows Store remote desktop app has just updated in the background and I now cannot connect to some servers. This may be due to lack of support for "server authentication", as the servers that are working seem to have that turned on, whereas the server I can't connect to don't. The connection hangs at "Connecting to desktop Configuring remote PC..."

Version of the client is 10.2.1646.
My windows version is Windows 10 Enterprise 1909 build 1863.1256.

I can connect using the old-style windows desktop mstsc.exe to all servers without issue. Have tried restart of PC and uninstall/reinstall without success.

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,305 questions
{count} votes

Accepted answer
  1. Blake Mitchell 81 Reputation points
    2021-01-20T15:29:38.257+00:00

    Version 10.2.1701.0 is now available in the store. You can go to the updates section, check for updates, then install. I have tested and it has resolved my issues.

    1 person found this answer helpful.

12 additional answers

Sort by: Most helpful
  1. Rafał Dumała 1 Reputation point
    2021-01-18T21:30:23.353+00:00

    Same here, problem since 10 hours, users cannot connect using Windows Store Remote Desktop app, mstsc works as usual. I'm not able to connect to WS 2012R2, WS 2016 and W2019 RDS.

    0 comments No comments

  2. Karlie Weng 15,196 Reputation points Microsoft Vendor
    2021-01-19T03:14:58.427+00:00

    Hello @Squibb, Stuart

    Please first refer to the general troubleshooting step :
    Remote desktop connection is sometimes stuck on the Securing remote connection screen

    Also please try reboot your Gateway server.

    Here's a thread for your reference.

    Best Regards
    Karlie

    ----------

    If the Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  3. Rafał Dumała 1 Reputation point
    2021-01-19T09:04:16.077+00:00

    no luck, in my case still not working, I restarted all servers yesterday, it was the first idea, I checked also both links but still the same, what is strange old application is working fine, only windows store remote desktop app is affected.

    0 comments No comments

  4. Squibb, Stuart 76 Reputation points
    2021-01-19T09:07:32.187+00:00

    Hi,

    There is no Gateway Server in this scenario. The connection is directly from my PC to the servers in question. MSTSC continues to work successfully.

    Regards,

    Stuart.

    0 comments No comments