Hi,
Please check the information on the Microsoft site below:
https://learn.microsoft.com/en-gb/troubleshoot/windows-client/deployment/windows-oobe-fails-start-new-computer
Cause
This issue occurs because the specific timing of the OOBE process causes a deadlock situation. This issue does not involve hardware, and you can easily fix it.
Workaround
For Issue 1 (“Something went wrong – But you can try again”), click Try again at the bottom of the screen. The OOBE process should continue as expected.
For Issue 2 (“Just a moment…”), press and hold the power button until the system turns off, and then turn on the system again. The OOBE process should resume and complete as expected.
If the issue still insists, I consider that the ISO file may be bad. Where did you get the image? Is it a custom image installation. If your system version is Windows 10, have you tried to download and create the ISO to install system in the link below.
https://www.microsoft.com/en-us/software-download/windows10
Hope this helps and please help to accept as Answer if the response is useful.
Best Regards,
Carl