how can the machine reach itself on public ip

Omer Anisfeld 6 Reputation points
2021-01-19T13:07:38.307+00:00

Hi,
I am trying to connect to my vm with specific port (5044).
I open this port in nsg but now I can only to telnet with private ip on the machine itself , if I tried to telnet with public ip I get a timeout error.
also I can't go to another machine in the same subnet and telnet public or private ip of this machine .

what should I do?
thanks

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
7,248 questions
Azure Virtual Network
Azure Virtual Network
An Azure networking service that is used to provision private networks and optionally to connect to on-premises datacenters.
2,197 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Omer Anisfeld 6 Reputation points
    2021-01-19T15:45:25.727+00:00

    I have under this subnet to vms
    kibana vm and logsash vm with the same NSG.
    I can connect to kibana with his pubilc ip and port 5044 but I still can't connect to logstash with his public ip
    so I think its not a problem of nsg.

    Option 2 doesn't work either

    Option 3: put in Local IP address my logstash private ip in port 5044 and Remote IP address the public ip that another machine with port 5044?
    If yes its work

    Option 4: I tried and it doesn't work

    I managed to resolve this by creating a new inbound rule on the NSG with the public IP of the server set as it's source and then of course the relevant port in question: I tried and it doesn't work

    when I compare between kibana vm and logstash vm I saw that the kibana has DNS name and logstah dosn't
    maybe this is the problem?

    0 comments No comments