Error An unknown command-line option /auto was specified Featues Update 1909

Anonymous
2021-01-20T08:23:23.53+00:00

Hello community.

I recently tried to make a Feature Update from an ISO of W10 1909 on a computer (due to compatibility issues with an application I cannot install the 20H2) it does not showme the option to update, it asks me to install directly, I tried run the following command E: \ setup.exe / auto upgrade / noreboot / dynamicupdate disable / compat scanonly to validate incompatibility issues and throw me the following message "An unknown command-line option /auto was specified" I tried to install all the updates that my computer could have pending and it did not work, I ran the SFC / SCANNOW and it did not find any infractions, also ran dism / online / cleanup-image / restorehealth and executed many reboots... not work, I tried on two more computers with the same ISO with the same result, later I decided to try on a fourth computer with the same ISO executing the E: \ setup.exe / auto upgrade / noreboot / dynamicupdate disable / compat scanonly command and IT WORKS, i can update in the fourth computer, I compared installed updates and the four computers have the same ones. What could be this error? and How can I solve it? I thank you in advance for your responses and I remain pending for any additional information you may require.

The four computers haves Windows 10 1809, Es-Es as default installed language and the ISO is Es-Es also.

Regards.

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,779 questions
{count} votes

Accepted answer
  1. Jenny Feng 14,081 Reputation points
    2021-01-20T09:32:48.9+00:00

    @Anonymous
    Hi,
    The /Auto option only works if you are inside a running copy of Windows 10 already and attempting to upgrade the installation that you are booted into.
    Where did you get the media from?
    If you can search your hard drive and the usb stick for an "unattend*.*" file then you can Simply booting from the media, should start setup without any options.

    Hope above information can help you.

    ============================================

    If the Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


3 additional answers

Sort by: Most helpful
  1. Anonymous
    2021-01-20T21:07:19.817+00:00

    Thanks @Jenny Feng for your answer, I get the media from the VLSC downloads portal, there is something curious, because in the computers 1 to 3 when i run the setup.exe from the ISO i get this
    58852-image-2021-01-20-14-11-17.png

    But in the 4 and 5 (another one that i test in the early morning) i get this result
    58871-image-2021-01-20-14-41-01.png

    (sorry, both images it's in Spanish)

    In the 4th computer there is no unatend.xml in the "C" drive, and in the 5th computer yes (C:\Unattend.xml), and in both it allows me to "upgrade", i tried renaming the unattend file in the 3rd computer And i can upgrade!, but i´m still needed the unatend.xml because it haves a configurations used in the original deployment.

    Resume of the tests:
    58843-image-2021-01-20-15-03-02.png

    Any ideas?

    P.D. Sorry for my bad translation, I'm still learning English

    (And thank for your answer again)


  2. James Madison (US - IFS) 1 Reputation point
    2021-05-17T19:05:27.513+00:00

    Any new info on this?

    I have 2 local VMs for testing and I am seeing this same issue whereas when I did this for 1909 I did not have any issues. I wish the error message was not so vague and misleading since /auto is a good command line.

    0 comments No comments

  3. James Madison (US - IFS) 1 Reputation point
    2021-05-19T18:45:01.507+00:00

    And same here I have 2 VM that are created with the same hardware specks using the same 1909 image where one can upgrade while the other can not. Not sure why there is not more info on this error since it does seem like a BS error given the fact that /auto is a good command line and I am running it while in the OS not winPe.

    0 comments No comments