Windows 10 installation tool can't find drivers

misel hader 1 Reputation point

Trying to install windows on new hard drive. I created a disc with .iso using installation media Microsoft media creation tool. When I try to install, I get message "cannot find drivers." What now?

Windows 10 Setup
Windows 10 Setup
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Setup: The procedures involved in preparing a software program or application to operate within a computer or mobile device.
1,916 questions
{count} votes

6 answers

Sort by: Most helpful
  1. Dave Patrick 426.3K Reputation points MVP

    Sounds like you may need to present the manufacturer disk controller driver during setup


    1 person found this answer helpful.

  2. Jenny Feng 706 Reputation points


    Welcome to our new Microsoft Q&A Platform.

    As recommended, since that's a new hard drive, you should download the disk controller driver from the manufacturer's website.

    Best Regards,

    1 person found this answer helpful.
    0 comments No comments

  3. Luan Vieira de Araujo 11 Reputation points


    I also had this problem and tried to solve it in many ways. The only way that really worked was to create a new installation media using MediaCreationTool (

    If the reply is useful for you, please take it as answer. If you have any other confuse, please reply to us directly.

    0 comments No comments

  4. Luigi Bruno 241 Reputation points

    Hi @misel hader .

    You wrote you're using a new hard drive: you have to prepare a USB drive containing the drive's controller driver and plug the USB drive when you need the disk and the partition where you want Windows to be installed, then click Load driver and browse to the USB drive for Windows to be able to locate the disk controller's drive and recognize the new disk.


    0 comments No comments

  5. nwohs 1 Reputation point

    I am writing concerning the installation of Windows 10 on a Fujitsu P1600 computer containing a newly formatted hard drive.

    I have exactly the same problem as described in the user forum but appear to have found a partial solution.

    The problem is the Microsoft installation tool. I downloaded an older version two years ago and updated 6 computers without problem including the Fujitsu P1600. The older version gave the choice of a 32 or 64 bit installation. Several machines were 32 bit.

    I recently had to reformat the drive and downloaded the new version of the install tool dedicated to 32 bit computers. This version caused the problem to the writers. It would not install Windows because it was looking for drivers.

    Today I tried the old version. It is now installing Windows 10 on the Fujitsu.

    I have a different problem now because it installs only the 64 bit version, so the original tool now has encountered some sort of problem.

    I would greatly appreciate whatever assistance is available. Obviously there are users seeking this type of help.

    0 comments No comments