Can't upgrade SQL Server 2016 to latest CU update.

JD Schmidt 31 Reputation points
2021-01-21T23:48:54.36+00:00

Hi, I am trying to install software that requires sql server 2016 SP2 with CU 11 (13.0.5998.27). It fails because it says I have 13.0.5103.6. I downloaded the latest CU and tried to install that however everything is greyed out and can't be selected (see screenshots below). I did confirm that sql server is on x64 and I am installing the correct architecture. However when I compare the version in the mssms I get the older version and when I go through the setup media it is showing the updated CU. Any idea how to fix or debug this? Thanks.

59250-screen-shot-2021-01-21-at-114400-am.png59311-screen-shot-2021-01-21-at-125723-pm.png59285-screen-shot-2021-01-21-at-114520-am.png59293-screen-shot-2021-01-21-at-11132-pm.png59159-screen-shot-2021-01-21-at-44315-pm.png59266-screen-shot-2021-01-21-at-44409-pm.png
59160-screen-shot-2021-01-21-at-44816-pm.png59321-screen-shot-2021-01-21-at-44526-pm.png

SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
12,904 questions
{count} vote

Accepted answer
  1. Erland Sommarskog 102.3K Reputation points
    2021-01-22T23:02:39.217+00:00

    I think the story is that you have been lead astray on the GDR train. That is, you have SQL 2016 SP2 without CU, but you have installed a few GDRs. It seems that in this situation there is no upgrade path to later CUs. I have experienced the same with an instance of SQL 2014 SP3, which I can't easily get to CU4.

    It is possible that if you uninstall the GDRs that you can come back to the train station and catch the CU train and install CU15, the latest CU (to which there also is a GDR). I have not tried this myself. (The instance I have problems with is a toy instance at home.)

    1 person found this answer helpful.

3 additional answers

Sort by: Most helpful
  1. Olaf Helper 41,411 Reputation points
    2021-01-22T06:54:50.723+00:00

    It fails because it says I have 13.0.5103.6

    And that's right, as one of the other screenshot also reports, you SQL Server is on that build version.

    59503--temp.png

    Which SQL CU installer did you used/which download link?


  2. Shashank Singh 6,246 Reputation points
    2021-01-22T07:30:55.417+00:00

    Don't confuse yourself with version of DB engine and and that of SSMS. The version of DB engine is that of 13.0.5103.6 while that of SSMS is 14..0.17289. Both are different and SSMS is totally different product from DB engine, its different installation now and does not comes with DB engine.

    0 comments No comments

  3. Cris Zhan-MSFT 6,611 Reputation points
    2021-01-25T03:03:08.317+00:00

    Hi @JD Schmidt ,

    The log files and screenshots indicate that the version of your SQL Server 2016 instance is now 13.2.5103.6. The current situation is that you cannot install any CU(for SQL Server 2016 SP2) for this instance.

    I suggest you uninstall this Security update(KB4583460) first , and reinstall the CU 15 for SQL Server 2016 SP2, finally install the Security update for SQL Server 2016 SP2 CU15(KB4583461)

    Check the Microsoft SQL Server Versions List for more details.
    https://sqlserverbuilds.blogspot.com/#sql2016x