Manually trace Query Performance that spike our CPU usage in Azure Database MariaDB 10.3

Mohd Khairi 1 Reputation point
2021-01-22T09:55:14.747+00:00

Query Performance Insight is not applied to Azure Database MariaDB 10.3. I there any other option that we can manually trace Query Performance that spike our CPU usage?

Azure Database for MariaDB
{count} votes

1 answer

Sort by: Most helpful
  1. Anurag Sharma 17,576 Reputation points
    2021-01-24T12:17:04.46+00:00

    Hi @Mohd Khairi , welcome to Microsoft Q&A forum.

    Currently the Query Performance Insight is not supported with version 10.3 on Azure MariaDB database. You can upvote this feature on the below uservoice link:
    https://feedback.azure.com/forums/915439-azure-database-for-mariadb/suggestions/39377131-would-be-great-if-we-have-intelligent-performance

    However, there are different ways through which we can check the performance of queries that take longer to execute and can cause higher CPU usage:

    1). Setting up alerts on specific metrics provided like cpu_percent, memory_percent etc. through alerts as mentioned in below article :
    https://learn.microsoft.com/en-us/azure/mariadb/howto-alert-metric

    59870-image.png

    2) Slow query logs: Setting up slow query logs and accessing the queries that are taking longer time and accessing them through Azure Monitor Logs:
    https://learn.microsoft.com/en-us/azure/mariadb/concepts-server-logs

    3). Using Query store to identify the long running as well as resource intensive queries. We would get the queries that take longer time based on parameters mentioned in the screenshot:
    https://learn.microsoft.com/en-us/azure/mariadb/concepts-query-store

    59948-image.png

    Clubbing alerts with these parameters can tell us when the spike happened and which queries were running then.

    Please let us know if this helps or else we can discuss further on the same.


    If answer helps, please select 'Accept Answer' as this could help others having similar queries.

    0 comments No comments