Verify tls version used from Client side.

Somnath Shukla 411 Reputation points
2021-01-23T04:13:45.06+00:00

From aspnet core 3.1 linux container hosted in aks I am calling azure sql server and azure redis cache. can u tell me how I can prove my client is using tls1.2 while on azure sql server tls 1.0 1.1 and 1.2 in enabled. On Azure Sql server i have not enabled minimum tls version.
Redis cache also support tls.1.0 1.1 and 1.2 there is no minimum tls version supported feature on azure redis cache.
I am using entity framework core 3.1.
i want verification from client side.
I need this for my audit

Azure SQL Database
Azure Cache for Redis
Azure Cache for Redis
An Azure service that provides access to a secure, dedicated Redis cache, managed by Microsoft.
222 questions
Azure Kubernetes Service (AKS)
Azure Kubernetes Service (AKS)
An Azure service that provides serverless Kubernetes, an integrated continuous integration and continuous delivery experience, and enterprise-grade security and governance.
1,902 questions
0 comments No comments
{count} votes

Accepted answer
  1. Somnath Shukla 411 Reputation points
    2021-02-08T08:24:48.557+00:00

    i figured it out .Net core 3.1 bluster slim base image has dropped support for tls 1.0 and 1.1 by default only tls 1.2 is enabled.
    we can confirm it by /etc/ssl/openssl.cnf file in base image.

    65304-image.png

    1 person found this answer helpful.
    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. JayaC-MSFT 5,526 Reputation points
    2021-01-28T11:41:41.2+00:00

    Hello @Somnath Shukla , I researched more on this and I see that this is application specific and needs dedicated troubleshooting. Our backend AKS or database logs might help. Hence I would request you to open a support ticket with Microsoft Support if you have a subscription which allows you to do so. Otherwise , you can send an email with subject line “Attn:Jaya” to AzCommunity[at]Microsoft[dot]com referencing this thread along with the subscription id.

    0 comments No comments