Unable to remove WAF

Bechir Gharbi 301 Reputation points
2021-01-25T13:03:40.537+00:00

Hello,
I created a front door with a WAF to test some scenarios then I deleted the front door before the WAF. Now I cannot remove the frontend host attached to the WAF so I cannot delete the WAF itself.

I got this error: Failed to update the Front Door '…'. Error: Resource group '…' could not be found.

I tried also to recreate the front door with the same old name in the same old resource group to delete the WAF but it was not possible and the same error.
By powershell with remove-azresourcegroup -name -force I got the error :
Remove-AzResourceGroup: Long running operation failed with status 'Conflict'.
StatusCode: 409
ReasonPhrase: Conflict

And with Remove-AzFrontDoorWafPolicy -ResourceGroupName -Name I got :
Remove-AzFrontDoorWafPolicy: FrontDoorWebApplicationPolicy could not be deleted because there are active resources linked to it. Please delete the linked resources and try again.

Even via Azure Resource Explorer the same thing.

Anybody has an idea or has seen that before ?

Azure Front Door
Azure Front Door
An Azure service that provides a cloud content delivery network with threat protection.
594 questions
0 comments No comments
{count} votes

4 answers

Sort by: Most helpful
  1. Kristoffer 11 Reputation points
    2021-01-25T13:57:25.063+00:00

    Did you just delete the Front Door?
    This sounds like lag in fabric, the Front Door is still not really removed, that might take some time.
    I'd advice you to wait an hour or so and then try to delete it again
    Recreating the Front Door possibly also caused some confusion for the fabric which causes it to take some time.

    If not I'd create a bug report or contact support
    Front Door is still a rather new products so there might be some remaining issues

    0 comments No comments

  2. Bechir Gharbi 301 Reputation points
    2021-01-26T09:10:19.887+00:00

    Hello,
    Thank you for the replay.
    I deleted the front door in the last week so it's not a problem about waiting an hour or 2.
    My Subscription does not include technical support. Yesterday I've sent an email to azurecommunity but no answer for now from them.

    0 comments No comments

  3. SaiKishor-MSFT 17,206 Reputation points
    2021-01-27T00:40:14.483+00:00

    @Bechir Gharbi I have reached out to you directly. Please let us know if you need any further assistance. Thank you!

    0 comments No comments

  4. Bechir Gharbi 301 Reputation points
    2021-02-05T07:49:57.047+00:00

    Hi,
    The issue was solved after opening a case with Microsoft Azure Support. The Background team has removed the frontend host attached to my waf then I was able to remove the waf.

    0 comments No comments