Error "To save to server, correct the invalid missing required properties"

Erdem Ayyildiz 116 Reputation points
2021-01-26T10:26:29.077+00:00

Hi Everyone,

The problem is like "To save to server, correct the invalid missing required properties" once open any office document with office application from specific document library. I checked properties of document and "Required" column of list but nothing related with that.
Environment:
SharePoint 2013
MS Office 2016

What are possible causes and solutions of this issue?

Thanks.

SharePoint Server
SharePoint Server
A family of Microsoft on-premises document management and storage systems.
2,243 questions
SharePoint Server Management
SharePoint Server Management
SharePoint Server: A family of Microsoft on-premises document management and storage systems.Management: The act or process of organizing, handling, directing or controlling something.
2,830 questions
{count} votes

Accepted answer
  1. Erdem Ayyildiz 116 Reputation points
    2021-02-02T17:13:53.933+00:00

    Okay, I've found the solution, here it is the explanation;

    When I try to look column type and information of Document via "Library Settings" or "SharePoint Designer" I could see only two column type information showed that are optional. Thus I decided to write magic PS script in order to retrieve all type and information of column.

    Add-PSSnapin Microsoft.SharePoint.PowerShell -ErrorAction SilentlyContinue
    $SiteURL="https://xxx.xxx/xx/xx"
    $ListName="XXX List"
    
    $web = Get-SPWeb $SiteURL
    $list = $web.Lists.TryGetList($ListName)
    $list.Fields | ?{$_.Required -eq "True"} | select Title,Required
    

    Once run this script, I noticed that there is a column which does not show in "Library Settings" like "RoutingRuleExternal". I decided to set "Required" property as "False" instead of delete the field, in any case.

    $ColumnName = "RoutingRuleExternal"
    $column = $list.Fields[$ColumnName]
    $column.Hidden = $false
    $column.ReadOnlyField = $false
    $column.AllowDeletion = $true
    $column.Required = $false
    $column.Sealed = $false
    $column.Update()
    

    Finally, try to edit documents with office application after refresh the page and happiness!

    Thank you all for great effort.


2 additional answers

Sort by: Most helpful
  1. Jerry Xu-MSFT 7,926 Reputation points
    2021-01-27T07:42:31.907+00:00

    Hi, @Erdem Ayyildiz ,

    Have you go to library settings and check all available columns? As you mention that only documents in a certain document library has this issue, will the same error occur if you upload a new file into this library?

    Also you can go to the File>info in office app, use the document inspector to remove the information and test whether the issue remains. Also, have you tried to edit the SharePoint properties in office?
    60830-image.png


    If an Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  2. sadomovalex 3,626 Reputation points
    2021-02-02T15:55:52.427+00:00

    does this document library uses custom content types? You may check that in Doclib settings > Advances settings > Allow management of content types - after that content types will be shown in Doclib settings. These content types may have required fields - may be one of these fields cause this problem.

    0 comments No comments