Why would SSIS package (create_execution) not run successfully?

Isabella Sturm 116 Reputation points
2021-01-26T22:05:26.55+00:00

I have an SSIS package uploaded to SQL Server 2012. It is being run from a web application and up until last week it was running fine. Then all of a sudden (during a demo no less) when I ran it, I got an error in my application basically alluding to the fact that the execution_id was not created and the package was not run.

When I try to run it again, or even try to query anything from SSISDB, the transaction times out and the queries never end or eventually end with a timeout error.

The strangest part is that right before the demo, I tested using the same execution parameters and it worked fine and now ever since it, it has been causing this issue starting only when I add certain parameters. Omitting the parameters and allowing the defaults works with no issue (until the failure occurs - this takes down the entire database/catalog).

I have looked up this issue and have found several solutions that include a link that gets redirected to the Microsoft "Microsoft Connect has been Retired" page which is not useful now in finding what had worked for others.

Here is a link to a StackOverflow Q/A that referenced this expired link: https://stackoverflow.com/a/19587866

SQL Server Integration Services
SQL Server Integration Services
A Microsoft platform for building enterprise-level data integration and data transformations solutions.
2,467 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Yitzhak Khabinsky 25,206 Reputation points
    2021-01-27T03:24:47.817+00:00

    @Isabella Sturm ,

    What is your SQL Server 2012 version?

    SELECT @@VERSION;  
    

    Please try to apply a latest SP and CU for SQL Server 2012.

    0 comments No comments