Conda environment locked by another AzureML job

Kanyan, Lawrence 11 Reputation points
2021-01-27T02:11:33.223+00:00

I tried to run an experiments. There was an error in my first submit and the run did not go through. However, a lock has been created which is preventing me from submitting further runs. I am getting the following error.

"The conda environment is currently locked by another AzureML job. Further job submission will wait until the other process finishes. If there are no other jobs running, please delete /home/azureuser/.azureml/locks/azureml_conda_lock"

I tried to use:
az ml run cancel -r exp_id

in CLI. However, this gives me an error:
Error, default experiment not set and experiment name parameter not provided.\nPlease provide a value for the experiment name parameter.

Azure Machine Learning
Azure Machine Learning
An Azure machine learning service for building and deploying models.
2,604 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Ramr-msft 17,621 Reputation points
    2021-01-27T12:23:43.017+00:00

    @Kanyan, Lawrence Thanks for the question. Could you please add more details about the steps/link to the code that you are trying.
    Here is the doc to configure and submit training runs.
    https://learn.microsoft.com/en-us/azure/machine-learning/how-to-set-up-training-targets#persistent