Win10 - Network Adapter Needs Resetting All The Time "default Gateway Not Available"

James Y 1 Reputation point
2021-01-27T15:20:53.91+00:00

Hi,

I have a long standing problem with the network adapter, or any network adapter i use with the PC. Several times a day, it seems to crash, losing network connection, and needs restarting by disabling then re-enabling on Device Manager, or via the troubleshooter (which does the same thing to fix the issue). Troubleshooter reports it as "Default Gateway Not Available".

It started with the onboard Killer E2400 adapter on the MB, but I also tried a separate internal adapter, and also a plug in USB adapter - all had exactly the same issue. In each case I disabled the other adapters and only had 1 enabled at a time.

On the system Event Log, it seems to line up with the following DistributedCOM error message on the Windows System logs:

The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
{2593F8B9-4EAF-457C-B68A-50F6B8EA6B54}
and APPID
{15C20B67-12E7-4BB6-92BB-7AFF07997402}
to the user JamesPC\James SID (S-1-5-21-688140728-383973141-2409692202-1000) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

Same message every time it fails.

Does anyone have nay idea what the problem is? I can find the Component Services administrative tool but have no idea what to look for. I've tried dozens of setting changes recommended by various websites but nothing seems to impact it.

Thanks very much!

Windows 10 Network
Windows 10 Network
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Network: A group of devices that communicate either wirelessly or via a physical connection.
2,285 questions
{count} votes