Azure Migrate RDP connection issue

Tristan Maritz (Administrator) 1 Reputation point
2021-01-28T08:25:23.987+00:00

I have 2 Severs protected by Azure Migrate ready for migration. When I test migration and try and connect to a VM by RDP it fails.

It has a NSG associated and a rule with highest priority
It has a Public IP associated
I have tried all the recommended troubleshooting (redeploying, resetting RDP, recreating NSG etc.) but the error I get when I try to test the RDP connection is 'Network connectivity blocked by security group rule: DefaultRule_DenyAllInBound' so clearly something quirky is happening that the new rule is not being recognised.

I tested by migrating with a NSG already setup and tried again setting one up after migration and also tried recreating one with MS support but same issue.

Any suggestions as it kind of makes Azure migrate useless if this cannot be resolved?

Thanks

Azure Migrate
Azure Migrate
A central hub of Azure cloud migration services and tools to discover, assess, and migrate workloads to the cloud.
729 questions
{count} votes