Power Query Merge dialog box blank

Nigel Barrett 1 Reputation point
2021-01-28T16:08:28.983+00:00

I am having a problem with Excel / Power Query that I had once before back in 2018. The only solution that worked then was to re-image the hard disk.

The problem manifests itself in two ways:

  1. When I open Power Query it is just white and the table does not show.
    Cannot close the PQ pane with the X have to press Alt F4 twice.
    Open PQ a second time and you can see the table of data.

2) When I try and do a merge the drop down selector for the second query is blank.
To do a merge I have to use the Advanced editor.

I have just had our IT dept completely uninstall O365 with a Registry clear out. The re-install.
Still had the same problem.

The fact that the only solution last time was a HD re-image makes me think that the problem is not in Excel / PQ itself. But it does not like something on my machine. Though nothing has been installed recently.

I have just installed the latest version of Office v2101 (build 13628.20274.

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
36,503 questions
{count} votes

3 answers

Sort by: Most helpful
  1. Ehren (MSFT) 1,781 Reputation points Microsoft Employee
    2021-03-17T22:42:15.83+00:00

    We have heard reports of this from time to time but we have never been able to narrow down the cause. Other than doing what worked last time (which is a pretty heavyweight solution), I would recommend that the next time this happens you:

    • Send feedback from within Excel
    • Check to see if Excel is running low on memory
    0 comments No comments

  2. Nigel Barrett 1 Reputation point
    2021-03-22T10:06:13.013+00:00

    Thanks for the reply.
    It is not a case of "when it happens again" it happens all the time. Every now and then it does not happen.
    Memory is fine. It is happening at the moment using less that 50% of 16 gb.

    0 comments No comments

  3. Fred Schwering 1 Reputation point
    2021-12-03T15:36:37.623+00:00

    I am having the same issue

    0 comments No comments