Configuration Option agent XPs changed from 0 to 1

Alexander Cardenas 21 Reputation points


A few days ago, on the log erro of the SQL Server i had the next message:

"[External]Configuration option 'Agent XPs' changed from 1 to 0. Run the RECONFIGURE statement to install. "

The solution of the issue it´s not important, i need to know what
produced this issue, could be an administrator or a program? .

**I don´t have the windows event log because it´s recycled every day. Only the SQL log.


SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
12,911 questions
0 comments No comments
{count} votes

Accepted answer
  1. Erland Sommarskog 102.3K Reputation points

    If you don't have auditing set up for these kind of things, it is about impossible to find out after the fact.

    It could be in the default trace if you are lucky, but I don't know this kind of event is captured there. And with five rollover files, the data in the default trace is not retained for a very long time.

    0 comments No comments

2 additional answers

Sort by: Most helpful
  1. CathyJi-MSFT 21,096 Reputation points Microsoft Vendor

    Hi @Alexander Cardenas ,

    Does your SQL server agent running now? Did you check your SQL server agent log to find some useful information? You can get them from SSMS UI when SQL agent running. Or you can get them from the default location C:\Program Files\Microsoft SQL Server\MSSQLX.MSSQLSERVER\MSSQL\Log.

    Each SQL Server Agent Error log will record informational, warnings and different error messages which have occurred since SQL Server Agent was last restarted or since the last time you have recycled the SQL Server Agent Error Logs.

    If the response is helpful, please click "Accept Answer" and upvote it, thank you.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments