What Options to migrate a VMware Vcenter Server 5.0 VM to Azure

Conrad 21 Reputation points

Hi, we are running VMware Vcenter Server 5.0 and would like to migrate a single VM to Azure.
IE As Is.
Its currently running a legacy version of Windows (2008R2/SQL2008).
The purpose is to keep it alive for the next couple of years only until the business have made the decision on the future for this data/product.
It would cost too much to try and upgrade the current environment to supported versions or leave it - 'as is' on premises.

But my issue is that all the documentation and options from Microsoft on this, seem to only support VMware v5.5 VMs.
So if i try and use the migration assistance etc, the OVF files and subsequent options are not compatible.
(i edited the OVF file so it would create the VM but it fails on permission access later)

I am happy to follow any process that allows the v5 VM to be created/migrated/imported - whatever, into Azure.
As long as we dont need to start upgrading the on premises systems to newer versions.
Anything possible?

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
7,515 questions
0 comments No comments
{count} votes

Accepted answer
  1. Leon Laude 85,716 Reputation points


    If you're willing to use Microsoft's methods/tools to migrate to Azure, then you'll require at least the vCenter to be at least version 5.5, unless you protect the virtual machine as physical as mentioned in the following thread:
    Migration to Azure from vSphere 5.0

    migration path for vCenter 5.0 or earlier

    If this isn't an option, then I suggest you use your favorite search engine to check if there are any third party solutions that supports migration from older vCenter to Azure.

    You may also try asking in the VMware forums for any help:

    (Please don't forget to mark helpful replies as answer)

    Best regards,

1 additional answer

Sort by: Most helpful
  1. Conrad 21 Reputation points

    In short, using the ASR, and following the physical server recovery works.
    The OVF file loads ok with Vsphere 5. Only a few error warnings at the start - which didnt seem to affect anything.
    I tried to see if i could add vsphere/vcentre credentials but this never worked. I think its looking for permissions which dont exist in v5.0 (i think they exist in v5.1).
    But if i skip the credential spot here, i was able to follow and complete the setup.
    I did end up installing the source server client manually but this might just have been my error when i was trying to also add vcentre permissions at one stage.
    and also completed a test failover.
    I then completed a replication to azure and then a failover test.
    Finally, i was able to remote into the server (used bastion) and it looked %100.
    NB: to speed up the replciation, i should have really cleansed to source server of "surplus files/junk".
    I had quite a few GBs of old files which i could easily have deleted prior.
    Our internet pipe isnt huge (20/20) but process never failed even though Azure was warning me of possible issues. (one being internet speed).
    Cheers for the direction to get here.

    0 comments No comments