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Blue screen BCCode:c2

Anonymous
2011-12-22T17:46:34+00:00

It’s some weeks when I try to turn on my laptop from hibernate or sleep, it restarts and the blue screen appears. I found the following error in problem history.

Thanks for your help.


Source

Windows

Summary

Shut down unexpectedly

Date

‎12/‎20/‎2011 4:41 PM

Status

Report sent

Problem signature

Problem Event Name:      BlueScreen

OS Version:        6.1.7601.2.1.0.768.3

Locale ID:           1033

Extra information about the problem

BCCode:             c2

BCP1:  0000000000000007

BCP2:  000000000000109B

BCP3:  0000000004440000

BCP4:  FFFFFA8006B17010

OS Version:        6_1_7601

Service Pack:     1_0

Product:             768_1

Bucket ID:          X64_0xc2_7_aPmI_HssDrv+2bac

Server information:           6ca6f7c9-9c06-46be-a06f-3c4c74f5e4d4

Windows for home | Previous Windows versions | Windows update

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Answer accepted by question author

Anonymous
2011-12-22T19:55:10+00:00

Hi,

See this thread for information on using BlueScreenView, MyEventViewer, and other methods to

troubleshoot BlueScreens - top 3 answers (+1 other).

http://answers.microsoft.com/en-us/windows/forum/windows_7-system/sometimes-i-get-a-blue-screen-when-using-ie-8/c675b7b8-795f-474d-a1c4-6b77b3fcd990 

We can analyze the minidumps if you make them available from the SkyDrive or other file

sharing sites (such as MediaFire). If you have problems uploading the minidumps copy

them to the Desktop or the Documents folder and upload them from there.

Zip or upload the contents of C:\Windows\minidump

Use SkyDrive to upload collected files.

http://social.technet.microsoft.com/Forums/en-US/w7itproui/thread/4fc10639-02db-4665-993a-08d865088d65


BCCode: C2   0x000000C2

This error is usually a driver issue and display adapter (video) driver is the most suspect though it

could be others. Antivirus/antispyware/security programs, hardware (heat) and major software issues

can also cause the error. When you get to the driver section of the troubleshooter use my generic

methods in the next message and then return to the troubleshooter if needed. Memory issues are

another possibility after drivers.

Have you added hardware recently or updated drivers? Be sure to look in Control Panel - Windows

Updates to see if any drivers were updated there. Other lessor possibilities include antivirus/anti-

spyware/security programs.


BCCode: C2   0x000000C2

Bug Check 0xC2: BAD_POOL_CALLER

The BAD_POOL_CALLER bug check has a value of 0x000000C2. This indicates that the current thread is making a bad pool request.

Important Information If You Have Received a STOP Code

If you have received a blue screen error, or stop code, the computer has shut down abruptly to protect itself from data loss. A hardware device, its driver, or related software might have caused this error. If your copy of Windows came with your computer, call the manufacturer of your computer. If you purchased Windows separately from your computer, Microsoft provides support. To find contact information for Microsoft or your computer manufacturer,  Contact Support.

If you have experience with computers and want to try to recover from this error, follow the steps provided in the Microsoft article  Resolving STOP (Blue Screen) Errors in Windows.

The following actions might prevent an error like this from happening again:

  1. Download and install updates and device drivers for your computer from Windows Update.
  2. Scan your computer for computer viruses.
  3. Check your hard disk for errors.

BAD_POOL_CALLER Parameters

The following parameters are displayed on the blue screen. Parameter 1 indicates the type of violation. The _POOL_TYPE codes are enumerated inNtddk.h. In particular, 0 indicates nonpaged pool and 1 indicates paged pool.

To see the possible parameters

http://msdn.microsoft.com/en-us/library/ff560185(v=VS.85).aspx

Cause

An invalid pool request has been made by the current thread.

Resolution

Activate Driver Verifier to obtain more information about these errors. For details, see the Driver Verifier section of the Windows Driver Kit (WDK).

BCCode: C2   0x000000C2  <-- read this link

http://www.faultwire.com/solutions-fatal\_error/BAD-POOL-CALLER-0x000000C2-\*1195.html?order=date

=========================================================

Driver Verifier can help find some BSOD issues :

Using Driver Verifier to identify issues with Windows drivers for advanced users

http://support.microsoft.com/kb/244617

How To Troubleshoot Driver Problems in Windows Vista or 7.

http://www.winvistaclub.com/t79.html

Using Driver Verifier

http://msdn.microsoft.com/en-us/library/ff554113(v=VS.85).aspx

How to use Windows Driver Verifier Manager to Troubleshoot & Identify Driver Issueshttp://www.youtube.com/watch?v=\_VwIDD9xngM

Driver Verifier

http://www.techsupportforum.com/2110308-post3.html

Using Driver Verifier

http://www.faultwire.com/solutions/using\_driver\_verifier.php

How to use Windows Driver Verifier Manager to Troubleshoot & Identify Driver Issueshttp://www.youtube.com/watch?v=\_VwIDD9xngM

You can disable Driver Verifier

http://support.microsoft.com/kb/244617

Start - type in Search box -> verifier /reset      hit enter to disable

Use BlueScreenView to see if there is a driver specified in the error message. Also

check with MyEventViewer at the time of the BlueScreen. (See the troubleshooter

above.)

Upload any minidumps created when you run DriverVerifier so we can analyze them.

=========================================================

=========================================================

Look in the Event Viewer to see if anything is reported about those.

http://www.computerperformance.co.uk/vista/vista\_event\_viewer.htm

MyEventViewer - Free - a simple alternative to the standard event viewer of Windows.TIP - Options - Advanced Filter allows you to see a time frame instead of the whole file.

http://www.nirsoft.net/utils/my\_event\_viewer.html


Also do this so you can see the likely bluescreens.

Windows Vista automatically restarts if your PC encounters an error that causes it to crash.

(also Windows 7)

http://www.winvistatips.com/disable-automatic-restart-t84.html


Here are some methods to possibly fix the blue screen issue. If you could give the Blue Screen info

that would help. Such as the BCC and the other 4 entries on the lower left. And any other error

information such as STOP codes and info such as IRQL_NOT_LESS_OR_EQUAL or PAGE_FAULT_IN_NONPAGED_AREA and similar messages.

As examples :

BCCode: 116

BCP1: 87BC9510

BCP2: 8C013D80

BCP3: 00000000

BCP4: 00000002

or in this format :

Stop: 0x00000000 (oxoooooooo oxoooooooo oxooooooooo oxoooooooo)

tcpip.sys - Address 0x00000000 base at 0x000000000 DateStamp 0x000000000

This is an excellent tool for posting Blue Screen Error InformationBlueScreenView scans all your minidump files created during 'blue screen of death'crashes, and displays the information about all crashes in one table - Freehttp://www.nirsoft.net/utils/blue\_screen\_view.html

Many BlueScreens are caused by old or corrupted drivers, especially video drivers however

there are other causes.

You can do these in Safe Mode if needed or from Command Prompt from Vista DVD or

Recovery Options if your system has that installed by the maker.

How to Boot to the System Recovery Options in Windows 7

http://www.sevenforums.com/tutorials/668-system-recovery-options.html

You can try a System Restore back to a point before the problem started if there is one.

How to Do a System Restore in Windows 7

http://www.sevenforums.com/tutorials/700-system-restore.html


Start - type this in Search Box ->  COMMAND   find at top and RIGHT CLICK  -  RUN AS ADMIN

Enter this at the prompt - sfc /scannow

How to Repair Windows 7 System Files with System File Checker

http://www.sevenforums.com/tutorials/1538-sfc-scannow-command-system-file-checker.html

How to analyze the log file entries that the Microsoft Windows Resource Checker (SFC.exe) program

generates in Windows Vista cbs.log (and Windows 7)

http://support.microsoft.com/kb/928228

The log might give you the answer if there was a corrupted driver. (Does not tell all the possible

driver issues).

Also run CheckDisk so we can rule out corruption as much as possible.

How to Run Check Disk at Startup in Windows 7

http://www.sevenforums.com/tutorials/433-disk-check.html


Often updating drivers will help, usually Video, Sound, Network Card  (NIC), WiFi, 3rd party

keyboard and mouse, as well as other major device drivers.

Manually look at manufacturer's sites for drivers - and Device Maker's sites.

http://pcsupport.about.com/od/driverssupport/ht/driverdlmfgr.htm

Installing and updating drivers in Windows 7 (updating drivers manually using the methods above

is preferred to ensure the latest drivers from System maker and Device makers are found)

http://www.sevenforums.com/tutorials/43216-installing-updating-drivers-7-a.html

Stop Windows 7 from Automatically Installing Device Drivers

http://helpdeskgeek.com/windows-7/stop-windows-7-from-automatically-installing-device-drivers/

How To Disable Automatic Driver Installation In Windows 7 / Vista

http://www.addictivetips.com/windows-tips/how-to-disable-automatic-driver-installation-in-windows-vista/

Disable Windows Update Device Driver Search Prompt In Windows 7 / Vista (for Professional,

Ultimate, and Enterprise)

http://www.addictivetips.com/windows-tips/disable-windows-update-device-driver-search-prompt/


How to fix BlueScreen (STOP) errors that cause Windows Vista to shut down or restart

unexpectedly

http://support.microsoft.com/kb/958233

Troubleshooting Vista Blue Screen, STOP Errors (and Windows 7)

http://www.chicagotech.net/vista/vistabluescreen.htm

Understanding and Decoding BSOD (blue screen of death) Messages

http://www.taranfx.com/blog/?p=692

Windows - Troubleshooting Blue Screen Errors

http://kb.wisc.edu/page.php?id=7033


In some cases this might be required.

StartUp Repair from Recovery Options or Windows 7 disk

How to Run a Startup Repair in Windows 7

http://www.sevenforums.com/tutorials/681-startup-repair.html

How to Boot to the System Recovery Options in Windows 7

http://www.sevenforums.com/tutorials/668-system-recovery-options.html

How to Create a Windows 7 System Repair Disc

http://www.sevenforums.com/tutorials/2083-system-repair-disc-create.html

How to Do a Repair Install to Fix Windows 7

http://www.sevenforums.com/tutorials/3413-repair-install.html

Hope this helps and Happy Holidays!


Rob Brown - Microsoft MVP <- profile - Windows Expert - Consumer : Bicycle - Mark Twain said it right.

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4 additional answers

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  1. Anonymous
    2011-12-23T07:52:25+00:00

    Hi,

    Results verified by WinDBG, DumpCHK, and BlueScreenView.

    The Bug_Check was C2 CAUSE HssDrv.sys Hotspot Shield Routing Driver AnchorFree Inc. 

    BugCheck C2, {7, 109b, 4440016, fffffa800433cbd0}

    Probably caused by : HssDrv.sys ( HssDrv+2bac

    MODULE_NAME: HssDrv

    IMAGE_NAME:  HssDrv.sys

    DEFAILURE_BUCKET_ID:  X64_0xc2_7_aPmI_HssDrv+2bac

    BUCKET_ID:  X64_0xc2_7_aPmI_HssDrv+2bac

    HssDrv.sys dated 9/2/2010 Hotspot Shield Routing Driver AnchorFree Inc.

    fffff88004c21000 fffff88004c3a000   HssDrv   T (no symbols)          

        Loaded symbol image file: HssDrv.sys

        Image path: \SystemRoot\system32\DRIVERS\HssDrv.sys

        Image name: HssDrv.sys

        Timestamp:        Thu Sep 02 10:46:48 2010 (4C7FE308)

    1. Check with HotSpot Shield Support for updates and/or possible solutions.

    HotSpot Shield

    http://hotspotshield.com/

    2. Use the other methods in the troubleshooters previously posted.

    Hope this helps and Happy Holidays!


    Rob Brown - Microsoft MVP <- profile - Windows Expert - Consumer : Bicycle - Mark Twain said it right.

    Was this answer helpful?

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  2. Anonymous
    2011-12-22T19:55:49+00:00

    Hi,

    References to Vista also apply to Windows 7.

    This is my generic how to for proper driver updates : (Check for BIOS and driver updates.)

    This utility makes it easy to see which versions are loaded :

    DriverView - Free - utility displays the list of all device drivers currently loaded on your system.

    For each driver in the list, additional useful information is displayed: load address of the driver,

    description, version, product name, company that created the driver, and more.

    http://www.nirsoft.net/utils/driverview.html

    For Drivers check System Maker as fallbacks and Device Maker's which are the most current.

    Control Panel - Device Manager - Display Adapter - write down the make and complete model

    of your video adapter - double click - Driver's tab - write down the version info. Now click UPdate

    Driver (this may not do anything as MS is far behind certifying drivers) - then Right Click -

    Uninstall - REBOOT this will refresh the driver stack.

    Repeat that for Network - Network Card (NIC), Wifi, Sound, Mouse and Keyboard if 3rd party

    with their own software and drivers and any other major device drivers you have.

    Now go to System Maker's site (Dell, HP, Toshiba as examples) (as rollback) and then Device

    Maker's site (Realtek, Intel, Nvidia, ATI as examples) and get their latest versions. (Look for

    BIOS, Chipset and software updates at System Maker's site while there.)

    Download - SAVE - go to where you put them - Right Click - RUN AD ADMIN - REBOOT after

    each installation.

    Always check in Device Manager - Drivers tab to be sure the version you are installing actually

    shows up. This is because some drivers rollback before the latest is installed (sound drivers

    particularly do this) so install a driver - reboot - check to be sure it is installed and repeat as

    needed.

    Repeat at Device Makers - BTW at Device Makers DO NOT RUN THEIR SCANNER - check

    manually by model.

    Manually look at manufacturer's sites for drivers - and Device Maker's sites.

    http://pcsupport.about.com/od/driverssupport/ht/driverdlmfgr.htm

    Installing and updating drivers in Windows 7 (updating drivers manually using the methods above

    is preferred to ensure the latest drivers from System maker and Device makers are found)

    http://www.sevenforums.com/tutorials/43216-installing-updating-drivers-7-a.html

    If you update drivers manually then it is a good idea to disable Driver Installations in Windows

    Updates, this leaves Windows Updates ON however it will not install drivers which will usually be

    older and cause issues. If Updates suggests a new driver then HIDE it (Right Click on it) and then

    go look for new ones manually if you wish.

    Stop Windows 7 from Automatically Installing Device Drivers

    http://helpdeskgeek.com/windows-7/stop-windows-7-from-automatically-installing-device-drivers/

    How To Disable Automatic Driver Installation In Windows 7 / Vista

    http://www.addictivetips.com/windows-tips/how-to-disable-automatic-driver-installation-in-windows-vista/

    Disable Windows Update Device Driver Search Prompt In Windows 7 / Vista (for Professional,

    Ultimate, and Enterprise)

    http://www.addictivetips.com/windows-tips/disable-windows-update-device-driver-search-prompt/

    ==========================================

    Memory tests do not catch all errors such as mismatched memory (possible even for sticks

    that appear to be identical) and when faster memory is placed in system behind slower memory.

    So it is best to also swap sticks in and out to check for those even if all memory tests fail to show

    a problem.

    To test RAM check here - let it run 4+ hours or so.   <-- best methodwww.memtest.org

    For the Vista/Windows 7 Memory Diagnostic Tool

    Start - type in Search box ->  Memory - find Memory Diagnostics tool at top of list - Right Click -

    RUN AS ADMIN follow the instructions

    Windows Vista: How to Scan / Test your RAM or Memory with Windows Vista Memory Diagnostic

    Tool

    http://www.shivaranjan.com/2007/11/01/windows-vista-how-to-scan-test-your-ram-or-memory-with-windows-vista-memory-diagnostic-tool/

    How to Run the Memory Diagnostics Tool in Windows 7

    http://www.sevenforums.com/tutorials/715-memory-diagnostics-tool.html

    Test Your Computer’s Memory Using Windows Vista Memory Diagnostic Tool

    http://www.howtogeek.com/howto/windows-vista/test-your-computers-memory-using-windows-vista-memory-diagnostic-tool/

    Hope this helps and Happy Holidays!


    Rob Brown - Microsoft MVP <- profile - Windows Expert - Consumer : Bicycle - Mark Twain said it right.

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  3. Anonymous
    2011-12-22T18:45:18+00:00

    Bug Check Code 0xC2

    http://msdn.microsoft.com/en-us/library/ff560185(v=VS.85).aspx

    Please post a copy of your dumpfile as a shared file to your Sky Drive with a link here.

    http://social.technet.microsoft.com/Forums/en-US/w7itproui/thread/4fc10639-02db-4665-993a-08d865088d65

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