Microsoft Hyper-V VSS Writer error

Jendislav 96 Reputation points
2021-02-03T07:53:07.023+00:00

Hello folks,
please can anybody help me with my issue?
Hyper-V host is Windows Server 2012 STD fully patched - disk C: 1,02TB / 34GB free. Hyper-V role installed. Backups have been running fine until last Friday.
1 VM - Windows Server 2012 STD (vhdx size i 1 TB) - contains users data and SQL server (disk C: 100GB/9GB Free, disk E: 400GB/200GB Free, Disk G: 600GB/16GB free).
I restarted host and VM, I ran SFC on host - no problem. VSS Writers are fine on VM.

VSS Writer Hyper-V VSS Writer - State [11] - Failed - Retryable error

Event ids App:
VSS 8224
The VSS service is shutting down due to idle timeout.
VSS 12322
Revert operation for volume \?\Volume{e6ad9468-64ff-11eb-9431-c81f66d9a950}\ has begun. Volume is being reverted to the shadow copy with id {5cfc7951-795c-4e8d-8797-3fff7afe4ecf}.

Operation:
Revert a Shadow Copy

Context:
Execution Context: Coordinator

Revert operation for volume \?\Volume{26ef4277-5440-11eb-942e-c81f66d9a950}\ has begun. Volume is being reverted to the shadow copy with id {9f6a537c-079f-42fc-9e43-0a9633bc6826}.

Error 8193
Volume Shadow Copy Service error: Unexpected error calling routine GetOverlappedResult. hr = 0x80070057, The parameter is incorrect.
.

Operation:
Revert a Shadow Copy

Context:
Execution Context: System Provider

Error 12293
Volume Shadow Copy Service error: Error calling a routine on a Shadow Copy Provider {b5946137-7b9f-4925-af80-51abd60b20d5}. Routine details RevertToSnashot [hr = 0x80042302, A Volume Shadow Copy Service component encountered an unexpected error.
Check the Application event log for more information.
].

Operation:
Revert a Shadow Copy

Context:
Execution Context: Coordinator

Warning 8229
A VSS writer has rejected an event with error 0x800423f3, The writer experienced a transient error. If the backup process is retried,
the error may not reoccur.
. Changes that the writer made to the writer components while handling the event will not be available to the requester. Check the event log for related events from the application hosting the VSS writer.

Operation:
PostSnapshot Event

Context:
Execution Context: Writer
Writer Class Id: {66841cd4-6ded-4f4b-8f17-fd23f8ddc3de}
Writer Name: Microsoft Hyper-V VSS Writer
Writer Instance ID: {c10637fe-642a-4465-a126-135dc697bab4}
Command Line: C:\Windows\system32\vmms.exe
Process ID: 2780

Event ids System:
partmgr - 58
The disk signature of disk 1 is equal to the disk signature of disk 0.

volsnap 16
The shadow copies of volume \?...4ff-11eb-9431-c81f66d9a950} were aborted because volume \?...4ff-11eb-9431-c81f66d9a950}, which contains shadow copy storage for this shadow copy, was force dismounted.

FilterManager 3
Filter Manager failed to attach to volume '\Device\HarddiskVolume3'. This volume will be unavailable for filtering until a reboot. The final status was 0xC03A001C.
Filter Manager failed to attach to volume '\Device\HarddiskVolume6'. This volume will be unavailable for filtering until a reboot. The final status was 0xC03A001C.

Thank you for any advise.

Hyper-V
Hyper-V
A Windows technology providing a hypervisor-based virtualization solution enabling customers to consolidate workloads onto a single server.
2,562 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Mico Mi 1,921 Reputation points
    2021-02-03T09:30:11.973+00:00

    Hi,
    What backup tool did you use? If you use windows server backup, will the same issue happen?
    Where is your backup destination, location disk or external drive?

    1. Snapshot creation may fail if file system errors are encountered. You can perform error checking on a volume by running chkdsk /f or chkdsk /r on it.
      For example, to check the C: drive, open an Administrator Command Prompt and run the following command:
      chkdsk c: /f
      Make sure to check each partition that is being backed up.
    2. VSS only supports NTFS formatted volumes. Use PHYLock instead of VSS if the volume is not formatted NTFS. As an example, a Dell utility partition being included in the backup can cause VSS to fail. Exclude the partition from the backup.
    3. Ensure the system is not running another service using the VSS provider at the same time as the backup is to be run. The VSS provider may not support multiple snapshots being created at the same time.
    4. Ensure the system isn't in setup mode by checking the following registry key:
      HKEY_LOCAL_MACHINE\SYSTEM\Setup
      The values SystemSetupInProgress and UpgradeInProgress should be set to 0 (zero) or not exist.
    5. If the problem started after installing a new program or service, try uninstalling the new program or service to resolve the problem.
    6. Providers that are created by parties other than Microsoft may cause problems.
      To view the list of installed providers, open an Administrator Command Prompt (right click command prompt and choose run as administrator) and run the following command:
      vssadmin list providers
      Consider uninstalling the software that installed any of the third party providers you find and try the backup again.
    7. Please try to restart the Hyper-V VMMS service and check the status of VSS writer again.
      If the vss writer remains in a failed state, find registry of Hyper-V recreate the Hyper- V VSS writer registry, backup, delete and import a new one from a working computer to see the result.

    Thanks for your time!
    Best Regards,
    Mico Mi

    -----------------------------

    If the Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  2. Jendislav 96 Reputation points
    2021-02-03T09:47:53+00:00

    Hello thank you for answer. Backups were taken without any issue until Friday, there had been no changes on the server or new installations. I use Altaro VM Backup and it worked well so far. I had a chat with Altaro as well and I has been told it is Microsoft related issue. Your questions:

      • Checkdisk has been planned and is waiting for restart of server.
      • all volumes are NTFS
      • System is not in setup mode.
      • there has been no new installations or programs
      • Microsoft File Share Shadow Copy provider and Microsoft Software Shadow Copy provider 1.0
      • Service restarted - write returned back to normal state, when I tried to take backup - state 11 - failed, last error - not responding.

    I dont know if SQL Server running on VM may cause the problem, or maybe low disk space might cause it?