VS 15 enterprise not installing on Windows 7 Sp1

Umer Chaudhary 1 Reputation point
2021-02-03T11:22:21.727+00:00

hello

I am trying to install Visual studio 2015 on Windows 7 ultimate Sp1 but I am getting this error "A Setup Package is either Missing or Damaged ".

I tried different ways to install it but still getting error.

I open vs exe with "Open as administrator".

I selected option "Download packages from internet " and pressed Retry, still got this error.

I selected "Please provide a location to search for the package" and pressed retry, same error came back.

I downloaded vs 2015 enterprise iso from official website and got same error.

I downloaded vs 2015 enterprise web downloader from official website and got same error.

I googled this issue and tried those solutions but i am still getting this error.

please any body faced this issue and solved it please help.

Visual Studio Setup
Visual Studio Setup
Visual Studio: A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.Setup: The procedures involved in preparing a software program or application to operate within a computer or mobile device.
979 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Anna Xiu-MSFT 26,651 Reputation points Microsoft Vendor
    2021-02-04T05:49:34.097+00:00

    Hi @Umer Chaudhary ,

    Welcome to Microsoft Q&A!

    Which version of Visual Studio is currently installed on your computer?

    The error “A Setup Package is either missing or damaged” often means your installation package is corrupted or damaged.
    Please try to use the FCIV.exe to verify the hash of your ISO file and check if the package is corrupted.

    In addition, we suggest you download the VS2015 Enterprise from the download page. During the installation, please temporarily disable any anti-virus software.

    Sincerely,
    Anna

    • If the answer is helpful, please click "Accept Answer" and upvote it.
      Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.
    0 comments No comments

  2. Umer Chaudhary 1 Reputation point
    2021-02-16T08:08:50.077+00:00

    Hello Anna

    Thank you for your kind reply.

    I downloaded VS15 Enterprise from your link. its giving same issue again.
    FCIV.exe link is giving 404 error.

    hope you have other solution for this.