Remote Move Migration to Exchange Online - Target Delivery Domains not showing up

Joe Grover 436 Reputation points
2021-02-03T22:08:14.57+00:00

We're in a hybrid configuration right now and starting the process of migrating mailboxes. We in IT have been moved, and I moved a couple of shared mailboxes over this morning. Now however I just tried to create a new migration batch and the Target Delivery Domain option only lists ourdomain.onmicrosoft.com rather than the various domains we have configured under Accepted Domains.

I've seen folks say it may be an Autodiscover issue, but the Microsoft Connectivity Analyzer shows no issues there. What other things could cause this?

Microsoft Exchange Hybrid Management
Microsoft Exchange Hybrid Management
Microsoft Exchange: Microsoft messaging and collaboration software.Hybrid Management: Organizing, handling, directing or controlling hybrid deployments.
1,910 questions
0 comments No comments
{count} votes

Accepted answer
  1. Andy David - MVP 142.7K Reputation points MVP
    2021-02-03T23:02:10.967+00:00

    Hey @Joe Grover , that is expected.

    The target delivery domain is the 365 domain when moving to Exchange Online

    If you were offboarding mailboxes back to on-prem, then the target delivery domain would be the on-prem accepted domain.


3 additional answers

Sort by: Most helpful
  1. Jim Mular 1 Reputation point
    2021-03-25T19:48:46.603+00:00

    Same deal here. Just earlier today I moved some mailboxes and was able to select our company domain. Now only the onmicrosoft.com domain is available. I'm very afraid to proceed with that settings.

    0 comments No comments

  2. Matthew Adamczyk 1 Reputation point
    2021-03-26T15:04:58.73+00:00

    Currently, we have the same issue. Test migrations fail because the TargetDeliveryDomain is set 'wrong'. I need to have the 'vanity' domain be the TargetDeliveryDomain. Many options were selectable in the past... (we're doing a tenant-to-tenant migration!)

    0 comments No comments

  3. Yaser Alattas 1 Reputation point
    2021-05-26T14:04:03.357+00:00

    Same issue here, but the difference that nothing is appearing is the TargetDeliveryDomain list at all.
    I have run few dry tests and I am pretty sure that Gmail API is functioning

    I appreciate your support

    0 comments No comments