Excel chart - change data labels reference

Tang, Ziqi 21 Reputation points
2021-02-04T06:14:11.073+00:00

I have a bar chart from the table, but I want the labels to display information in "Category", not the number. Is there any way that I can achieve it in a easy way? Thanks.

63827-1.png

63798-2.png

PowerPoint Management
PowerPoint Management
PowerPoint: A family of Microsoft presentation graphics products that offer tools for creating presentations and adding graphic effects like multimedia objects and special effects with text.Management: The act or process of organizing, handling, directing or controlling something.
222 questions
Excel Management
Excel Management
Excel: A family of Microsoft spreadsheet software with tools for analyzing, charting, and communicating data.Management: The act or process of organizing, handling, directing or controlling something.
1,653 questions
0 comments No comments
{count} votes

Accepted answer
  1. Lz._ 8,991 Reputation points
    2021-02-04T16:00:17.497+00:00

    @Tang, Ziqi

    I don't have Excel 2016 but don't think that doesn't matter. Looking at your image more carefully, "TMMTTM" appears at the top of only 1 histo. bar while Numbers appear at the top of the other bars. This means something went wrong when you did it OR the process is slightly different with Excel 2016

    Please try again, making sure that at #3 all numbers are selected BEFORE you Check option "Value From Cells". You can also download my demo from this link to check this displays as expected on your side


1 additional answer

Sort by: Most helpful
  1. Lz._ 8,991 Reputation points
    2021-02-04T09:38:43.263+00:00

    Hi @Tang, Ziqi

    PIC

    (Done with Excel 365 for Windows) With the above range:
    1/ Select A1:B7 > Inser your Histo. chart
    2/ Right-click i.e. on the 1st histo. bar (A) > Add Data Labels (numbers are displayed a the top of the bars)
    3/ Click one of the numbers that just displayed (the Format Data Labels pane opens on the right) > Check option "Value From Cells" > Select range C2:C7 > OK > Uncheck option "Value"