Windows 2019 RDS Servers Start Menu Stopped Working

Paul Allan 6 Reputation points
2021-02-04T10:30:35.18+00:00

We are also running a 2019 RDS Farm and we have had this exact same issue with the Start Menu not working this week. Initially it was on one host, and now it is happening on two hosts! We ran the command on one host and it has fixed it. We have not ran it on the second host yet, as we had to stop it taking connections as it was causing so many issues for users.

Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

Does MS know why this is happening? Has a Jan update caused this issue? It is very worrying since most of our staff are currently WFH and are relying on the RDS servers to be able to work effectively.

Many Thanks
Paul.

Windows Server 2019
Windows Server 2019
A Microsoft server operating system that supports enterprise-level management updated to data storage.
3,507 questions
Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,286 questions
Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,294 questions
{count} vote

5 answers

Sort by: Most helpful
  1. Davide Filia 31 Reputation points
    2022-09-30T13:22:35.98+00:00

    Hello,
    RDS environment with 3 SH.
    Users via published applications (web apps) had the anomaly of not being able to activate the O365 license due to the password request windows not displayed.
    With my user in RDP I realized that the start menu was not working and cause this issues.
    Like @Paul Allan at the first time after PS command Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$ ($ _. InstallLocation) \ AppXManifest.xml"}
    it worked correctly, but only for a few hours.

    After countless attempts and backup restores I found these commands:

    reg delete HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\FirewallRules /va /f

    reg delete HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\RestrictedServices\Configurable\System /va /f

    reg delete HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\RestrictedServices\AppIso\FirewallRules /va /f

    Especially for the last one you have to be patient, in my case there were thousands of records
    Without restart the server after a few minutes the start menu started working again !!!

    I hope this commands can work for you too.

    6 people found this answer helpful.

  2. John Fournier 35 Reputation points
    2023-06-21T13:32:31.1466667+00:00

    If anyone is still struggling with this, here's the fix.

    It was addressed in this update: https://support.microsoft.com/en-gb/topic/march-26-2019-kb4490481-os-build-17763-402-c323e5c1-d524-dbdb-04a0-c3b5c8c8f2fd

    Specifically,

    Addresses an issue that slows server performance or causes the server to stop responding because of numerous Windows firewall rules. To enable this solution, use regedit to modify the following and set it to 1:

    Type: “DeleteUserAppContainersOnLogoff” (DWORD)

    Path: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy

    I found the answer here: https://community.spiceworks.com/topic/2285411-server2019-rds-hundreds-of-firewall-rules-per-user-per-session

    1 person found this answer helpful.
    0 comments No comments

  3. Karlie Weng 15,186 Reputation points Microsoft Vendor
    2021-02-05T02:42:08.823+00:00

    HI

    How about adding the following commands to the users login script:
    Add-AppxPackage -Register "C:\Windows\SystemApps\ShellExperienceHost_cw5n1h2txyewy\AppxManifest.xml" -DisableDevelopmentMode
    Add-AppxPackage -Register "C:\Windows\SystemApps\Microsoft.Windows.Cortana_cw5n1h2txyewy\AppxManifest.xml" -DisableDevelopmentMode

    Thanks
    Karlie


  4. Jean-Luc Ch 176 Reputation points
    2021-03-25T10:55:01.343+00:00

    Hi,
    Same issue. I tested custom start menu (.xml file). It works fine when first log on server. Next times, no more start menu.

    As workaround, I see that:

    https://social.technet.microsoft.com/Forums/en-US/abb99ec6-0996-4e0e-a7eb-d76c255edb58/user-profile-disks-2016-and-start-menu?forum=winserverTS

    It permits to restore some access, but:

    • tiles are missing
    • I'm not sure that "customized" start menu deployed with GPO is effective

    I openend a Ms support case...

    Regards

    0 comments No comments

  5. Randy Weiss 1 Reputation point
    2021-04-09T15:36:53.047+00:00

    I've been troubleshooting similiar issues and I found this post that windows search is corrupting the user edb on server 2019 because the edb is moved to the appdata\roaming folder which is abruptly removed while the indexer is still accessing it. Maybe this is causing your issues too. Their solution was to create a scheduled task to restart the Windows search service on a user logout event ID.

    https://jkindon.com/2020/03/15/windows-search-in-server-2019-and-multi-session-windows-10/

    0 comments No comments