Latest data is not available in Sync errors AAD

HavrilyukRoman 21 Reputation points
2020-05-08T18:49:54.147+00:00

Hello community.
I set up AzureAD Connect and AAD Connect Health service on my premise server, and its works fine. Sync works fine, and i have some sync errors, but i saw it in aad admin console.
Then i added second server, with AAD Connect in staging mode, configure it like on first server and after i install health service on seconds server. After that there is warning text in Azure Active Directory Connect Health | Sync errors, 7966-annotation-2020-05-08-214855.pngthat latest data is not avaliable.
What i already tried:
I reinstall AADCH on first server
I runned that commandlet below
on first (main) server:
Register-AzureADConnectHealthSyncAgent -AttributeFiltering $false -StagingMode $false
and on seconds (staging) server:
Register-AzureADConnectHealthSyncAgent -AttributeFiltering $false -StagingMode $true

On both server test connectivity tell that all ok:
Test-AzureADConnectHealthConnectivity -ShowResult -Role Sync
Test-AzureADConnectHealthConnectivity completed successfully... (3/3)

Sync works as should, but i want to get back my sync errors information.
Please, help.

Azure Active Directory
Azure Active Directory
An Azure enterprise identity service that provides single sign-on and multi-factor authentication.
12,772 questions
No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Marilee Turscak-MSFT 20,676 Reputation points Microsoft Employee
    2020-05-08T23:24:22.917+00:00

    Did you receive a message that the registration was successful after you registered? And did you try to log in in a new browser after completing that?

    If it's still not working you should test your on-premises firewall settings. Make sure TCP/UDP 443 and TCP/UDP 5671 are open.

    https://learn.microsoft.com/en-us/azure/active-directory/connect-health/active-directory-aadconnect-health-agent-install

    Otherwise, if all of this is fine, it is likely that you either need to 1.) update to the latest health agent; or 2.) Ensure that data freshness alerts are active on the service https://learn.microsoft.com/en-us/azure/active-directory/hybrid/how-to-connect-health-data-freshness

    Hope this helps!

    No comments