sql server 2008r2报错无法登录 error40

鹏 柳 96 Reputation points
2021-02-08T02:14:42.35+00:00

您好
sql server 2008r2报错无法登录 error40
报错内容

     “在与SQL Server建立连接时出现与网络相关的或特定于实例的错误。未找到或无法访问服务器。请验证实例名称是否正确并且SQL Server已配置为允许远程连接。(provider:命名管道提供程序,error;40 - 无法打开到SQl Server的连接) (Microsoft SQL Server,Error:2)”  

65073-error40.jpg

SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
12,897 questions
{count} votes

2 answers

Sort by: Most helpful
  1. CathyJi-MSFT 21,096 Reputation points Microsoft Vendor
    2021-02-09T08:38:47.477+00:00

    Hi @鹏 柳 ,

    This is a Q&A forum in English. Suggest you post your issue in English to get better help.

    For your issue, please follow below steps to troubleshot the issue,

    1. Make sure SQL Server Service is running
    2. If a named instance, make sure SQL Server browser service is running. Make sure the instance name is spelled correct and there is actually such an instance on your target machine.
    3. Make sure SQL Server is configured to allow remote connections
    4. Examine the SQL Server error log for messages confirming that SQL is listening on the expected network interfaces and ports
    5. Test server connectivity with PING from the client machine
    6. Test port connectivity using TELNET to the server and port (from step 4) from the client machine. For example
      TELNET <server-name> 1433
    7. Check firewall settings if step 5 or 6 connectivity test fails

    If you have some confuse about the steps, please refer to the blog Resolving could not open a connection to SQL Server errors or MS document Troubleshoot connecting to the SQL Server Database Engine to get more information.


    If the response is helpful, please click "Accept Answer", thank you.

    0 comments No comments

  2. 鹏 柳 96 Reputation points
    2021-02-18T06:49:34.643+00:00

    OK, thank you. I'll try the operation method. If I can solve it, I'll share it with you.

    0 comments No comments