Sleep button can still be select if acpi device not define.

xxxljp 101 Reputation points
2020-05-11T16:17:51.797+00:00

Hi,

I had a question about sleep button under windows,
and following condifions are shown:

  1. windows 10.0.18363.418
  2. acpi facp flag bit 5 = 1, sleep button not support
  3. can't find sleep button acpi device in asl code.

According to aboves conditions,
sleep button should be hidden or gray out,
but sleep button in power option can still be selected.

Does anyone know is it normal behavior of windows 10?

thank you.

Reference:

Table 5-34 Fixed ACPI Description Table Fixed Feature Flags
P.137
ACPI_6_3_final_Jan30.pdf

7973-00-error-sleep-button-still-valid.jpg

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
37,748 questions
0 comments No comments
{count} vote

Accepted answer
  1. xxxljp 101 Reputation points
    2020-05-28T07:45:13.79+00:00

    When un-plug USB key Board, and enter power option again,
    then sleep button icon is disappear.

    With follow conditions :
    i. Acpi facp flag bit 5 = 1, sleep button not support.
    ii. Don't define ACPI device SLPB (PNP0CE) .

    So, we take some keyboard for short test,
    Wired USB Keyboard Product name :

    1. Logictech : K120.
    2. Logictech : Y-BP62A.
    3. Microsoft : Wired Keyboard 200.

    Test result :
    keyboard 1 & 2, Sleep button icon in power option still exist.
    keyboard 3, Sleep button icon in power option disappear.

    So, this sympton cause by following reasons :
    x. windows ospm doesn't reference acpi name space for Sleep button icon.
    xx. Keyboard firmware doesn't remove funtion completely even keyboard without sleep button.

    Thank you.

    0 comments No comments

2 additional answers

Sort by: Most helpful
  1. Sean Liming 4,591 Reputation points
    2020-05-11T16:26:42.79+00:00

    The sleep button should not be availabe.
    If you click on the sleep button does the system actually go to sleep?

    If you go to Control Panel->Power Options. Select Change Plan settings for the current plan, and then Change Advanced Power Settings. Go down the list and see what is available for the Sleep Button. Is a sleep option available?

    In your pictures, there is a "Change settings that are currently unavailable". did you click on this by any chance?


  2. Roy Li - MSFT 32,731 Reputation points Microsoft Vendor
    2020-05-12T02:40:42.257+00:00

    Hello,

    Welcome to Microsoft Q&A!

    Currently, Microsoft Q&A is under a public preview. All the supported topics are on the right top.

    Your issue is not supported right now. There is a better place for asking questions about windows 10, you could ask about this issue in Windows 10 General forum.

    Thank you.