"You do not have any Azure subscriptions in the Microsoft Learn Sandbox directory. Click here to switch to another directory." showing up in my notifications of Microsoft Learn account

Klark Ahmeti 31 Reputation points
2021-02-08T09:32:20.57+00:00

My question is straightforward. How to resolve this problem ? I've seen some other answers but none of them has worked so far.

Azure Cost Management
Azure Cost Management
A Microsoft offering that enables tracking of cloud usage and expenditures for Azure and other cloud providers.
2,140 questions
{count} votes

5 answers

Sort by: Most helpful
  1. Bamidele Ajamu 26 Reputation points
    2021-09-28T10:12:56.077+00:00

    All you need to do to resolve this issue is use a brand new browser which does not have your previous sign in to Azure. This works very well for me.

    The issue with the previous error was because one has signed in to azure with another username or email and the system is confused as to which email to sign in with. Microsoft needs to work on this though.

    With a new browser, you can use the sandbox app

    5 people found this answer helpful.

  2. Vaibhav Chaudhari 38,661 Reputation points
    2021-02-08T09:40:39.447+00:00

    Can you try click on below icon and select the sandbox subscription that is activated.. Inside this subscription, you are supposed to create services

    65290-image.png

    ----------

    Please don't forget to Accept Answer and Up-vote if the response helped -- Vaibhav

    2 people found this answer helpful.

  3. Brian Young 6 Reputation points
    2021-03-30T05:22:14.587+00:00

    Most of the answers here are nonsense, even after going to previous LEARN modules and resetting the sandbox I continued to get the same error. This included trying to "un"-delete resources using Azure shell... what worked for me was simply opening a private window in Firefox (I imagine similarly, incognito window in Chrome), and... magically, I was able to create resources/storage/etc in Azure within my LEARN sandbox and complete the "check my work" link from the LEARN module. In its own way, working around M$ limitations should be a part of the learning but being locked out of sandbox access while studying Ignite modules is nonsense... not to mention the FIX makes ZERO SENSE. But, if you're looking down the barrel of 99% completion, as I was, for the Azure Admin challenge.. or likely any other that requires "CHECK MY WORK" -- the fix is a clear cache private browser, inexplicably. I hope this helps someone, since the obvious alternative is to "wait out" the sandbox expiry, which ALSO DOESN'T WORK!

    1 person found this answer helpful.
    0 comments No comments

  4. Rishi Kapur 0 Reputation points
    2024-01-05T02:50:40.0533333+00:00

    Go to settings > Directories > Click on switch. It will fix that error.

    0 comments No comments

  5. Urszula Mucha 0 Reputation points
    2024-04-27T23:50:55.8366667+00:00

    User's image

    You must activate your sandbox in the course window (see the left side of my screenshot), and wait a minute for the Azure Cloud Shell (see the right side of the picture). You might need to repeat the bot verification.
    Only then try to open the Azure link, and the account shouldn't bug You for a subscription.

    Hope this helps!