virtual machines

Закар Закар 1 Reputation point

how to speed up internet on my server

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
7,281 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Monalla-MSFT 12,121 Reputation points

    Hello @Закар Закар - Thanks for reaching out.

    Azure virtual machines (VM) have default network settings that can be further optimized for network throughput.

    If your Windows VM supports Accelerated Networking, enabling that feature would be the optimal configuration for throughput.

    For all other Windows VMs, using RSS can reach higher maximal throughput than a VM without RSS. RSS may be disabled by default in a Windows VM. To determine whether RSS is enabled, and enable it if it's currently disabled, please follow the below steps :
    See if RSS is enabled for a network adapter with the


    PowerShell command. In the following example, if you see the output like below, then RSS is not enabled.

    Name : Ethernet
    InterfaceDescription : Microsoft Hyper-V Network Adapter
    Enabled : False

    To enable RSS, enter the following command:

    Get-NetAdapter | % {Enable-NetAdapterRss -Name $_.Name}

    The previous command does not have an output. The command changed NIC settings, causing temporary connectivity loss for about one minute. A Reconnecting dialog box appears during the connectivity loss. Connectivity is typically restored after the third attempt.

    Confirm that RSS is enabled in the VM by entering the Get-NetAdapterRss command again. If successful, the following example output is returned:

    Name : Ethernet
    InterfaceDescription : Microsoft Hyper-V Network Adapter
    Enabled : True

    For Linux VM, RSS is always enabled by default. For more details on optimizing network for Linux VM, please go through this document - virtual-network-optimize-network-bandwidth

    If the above response helped, Please "Accept as Answer" so it can beneficial to the community.

    0 comments No comments