Configuration Connectors in Office 365 Exchange

Roland 1 Reputation point


we just changed some days ago to Office 365. We also have a dedicated CES solution and for that we wanted to pass all emails via the Cisco for Inbound and Outbound. We got documentation from Cisco how to create the connector and the rules in Exchange Online.

Now we would like to bypass some domains from the CES and therefore create an exception in connectros and rules:

  1. We created a new connector from O365 to Partner Organization.
  2. We created a new rule Outbound for exception Domains:
    If the message...
    recipients's address domain portion belongs to any of these domains: ''
    and Is received from 'Inside the organization'
    Do the following...
    Route the message using the connector named 'Exception for special Domains'.
    and Set audit severity level to 'Do not audit'
  3. We put the rule above our existing rule to Outbound CES:
    If the message...
    Is sent to 'Outside the organization'
    and Is received from 'Inside the organization'
    Do the following...
    Route the message using the connector named 'Outbound to Cisco CES'.
    and set message header 'X-OUTBOUND-AUTH' with the value 'XXXXX`

Unfortunately it doesnt work, emails get send via the CES. Our MS support told us it is because of the connector and that we should delete the old conector to the CES.

I dont know it this makes sense because there is configured the routing to our MX of the CES.

Any way that both conectors work and we can easily define exception domains so that they will be sent out via the Exchange?

Thanks for your help!

Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,405 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Andy David - MVP 142.8K Reputation points MVP

    Instead of "recipients' address domain portion belongs to any of these domains:"

    Try: "includes these words in the recipient's address"


    Also, I would set the auditing level to high so it ends up in message tracking when the rule is applied.

    0 comments No comments

  2. Kael Yao-MSFT 37,576 Reputation points Microsoft Vendor

    Hi, @Roland

    Did you select "Stop processing more rules" on your new rule(Outbound for exception Domains)?
    It will avoid applying additional rules once this rule processes a message.

    If not,please select it and see if the message would be sent using the correct connector.

    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.