HPE Storage Management Pack 3PAR (ver 5.3-5.4)

Peter Svensson 211 Reputation points
2021-02-10T08:42:23.833+00:00

Hi

We are having an issue with the HPE Storage Management Pack, ver 5.3-5.4. Its not discovering any 3par devices. Using the older version 4.6, everything works.
According to HP Support:
I have checked and found that in scom mgmt 5.4 and latest version the agent action account needs to be a domain user which has scom database read access for discovery to work fine this is different in older version prior to version 5

It seems like HP wants us to change the Service account for the monitoring agent on the Management Server. This sounds strange to me. Anyone familiar with this setup?

Operations Manager
Operations Manager
A family of System Center products that provide infrastructure monitoring, help ensure the predictable performance and availability of vital applications, and offer comprehensive monitoring for datacenters and cloud, both private and public.
1,437 questions
0 comments No comments
{count} votes

6 answers

Sort by: Most helpful
  1. AlexZhu-MSFT 5,551 Reputation points Microsoft Vendor
    2021-02-11T06:18:18.113+00:00

    Hi,

    I know little about HPE Storage. Since this is the requirement of the MP, is there any chance for us to create a new action account, grant the permission and have a try? If it works, we may contact HP support once again to check why this is needed.

    https://learn.microsoft.com/en-us/system-center/scom/manage-security-create-runas-actionaccount?view=sc-om-2019

    Alex
    If the response is helpful, please click "Accept Answer" and upvote it.

    0 comments No comments

  2. AlexZhu-MSFT 5,551 Reputation points Microsoft Vendor
    2021-03-01T01:13:37.997+00:00

    Hi,

    It seems there is no update for a couple of days. May we know the current status of the problem? Is there any other assistance we can provide?

    Regards,

    Alex
    If the response is helpful, please click "Accept Answer" and upvote it.

    0 comments No comments

  3. Peter Svensson 211 Reputation points
    2021-03-02T07:09:25.053+00:00

    Short answer is that I'm still working with HP with this one.

    We have one Collection Server and one SCOM Management Server. The discovery is supposed to be done from the SCOM Management Server and the Collection Server receives traps.

    The discovery from the SCOM Management Server is not working. However, if we use the Operations Manager Action Account in a Run As Account on the collection server (using profile HPEnterpriseStorage3PARMP_HPDiscoveryAccount) it works.
    Since the SCOM Management Servers uses this account as default it "should" work, but doesn't.

    Done tracing on the discovery workflow but we cant see anything. Unfortunately HP doesn't seem to know what could be wrong either.

    0 comments No comments

  4. CyrAz 5,181 Reputation points
    2021-03-02T11:09:10.51+00:00

    It's not super easy to help you on this one since I don't have a SCOM environment running with 3par hardware available, and also since the latest versions of the 3par MPs are not indexed in systemcenter.wiki.

    However I don't really see how the discovery could be running "from the management server" while enabling "the collection server" to receive traps? Could you explain in more details how it's done/how it's supposed to work?

    It would make more sense that the discovery is running on the collection server, which seems to be confirmed by the fact that you have to manually specify the management server action account in the runas profile. As you said, if the discovery was running on the management server, it would use that account by default...

    0 comments No comments

  5. Peter Svensson 211 Reputation points
    2021-03-02T11:59:33.823+00:00

    I think we can drop this unless someone else has experience with the specific version of the Management Pack.
    So you can close the thread

    0 comments No comments