Install LAPS through VPN connection

David Leal 41 Reputation points

I'm deploying LAPS (local administrator password solution), I've three different scenarios:

  • Workstations wired connected in the office: It works perfectly.
  • Workstations wireless connected in the office: I doesn't work.
  • Workstations at home connected using a VPN: I doesn't work.

Installation GPO is quiet simple:


The source is a shared accesible folder through wirelees and VPN.
Nowadays 90% of the company is working at home with VPN connection. All other GPOs are working fine.

A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.
4,929 questions
0 comments No comments
{count} votes

Accepted answer
  1. Fan Fan 15,306 Reputation points Microsoft Vendor

    Not all Group Policy extensions are processed during a background refresh.
    Some of the group policies require a foreground (restar or logoff /login) to process .Such as software installation (need restart ), startup script.
    If the VPN or Wireless can't be connected at start up, then the group policies (Startup scripts ,software installation) won't process.

    I would recommend you talk to your network teams and confirm if the VPN or the wireless can be set to be connected at startup.
    Have no idea how did you configure the VPN, following link just for your reference:

    Best Regards,

    0 comments No comments

2 additional answers

Sort by: Most helpful
  1. Fan Fan 15,306 Reputation points Microsoft Vendor

    If there are any updates, welcome to share here!
    Best Regards,

    0 comments No comments

  2. Steve Vickroy 1 Reputation point

    There is a solution to the wireless issue. There is a setting to wait until the wireless connection is completed before processing the gpo. I use this for LAPS workstation installs over wireless.

    Computer Configuration -> Administrative Templates -> System -> Group Policy -> Specify startup policy processing wait time


    This will fix your wireless issue but not the vpn issue.

    0 comments No comments