Windows 2019 Std gui and logon logout freezes

Kamil Langa 21 Reputation points
2021-02-10T12:54:45.59+00:00

Hello,

we're having weird issues with our Windows 2019 std VM installations with RDS.

RDS servers are freezing (not entirely, more like slow down very much ), when they do we see very long logons do rdp (even 10 minutes). Windows GUI is responsing slowly and Task manager opens up but won't draw anything for few seconds then starts. These slow downs are totally random. Programs won't open instantly but after 40s and so on.

When loging on we see warnings associated with long GPO executions, but that's an effect not cause of the problem.

We excluded Network problems, SAN problems, CPU overload and RAM shortage. All resources are available but it still happens, even after hours.

VM's are on Windows 2016 Hyper-V servers, disks are on HPE 3PAR 8200 full SSD provisioned to hosts in as clustered shared storage.

We have 5 of those VM's and all of them are behaving line that, but not at the same time. It's totally random for all of them.
2 of those are on the same host when 1 slows down the other is functioning normally.

Did anyone encounter such problems with RDS on Win2019 ?

Any ideas appriciated.

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,446 questions
Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,339 questions
0 comments No comments
{count} votes

Accepted answer
  1. Eleven Yu (Shanghai Wicresoft Co,.Ltd.) 10,706 Reputation points Microsoft Vendor
    2021-02-11T07:28:04.957+00:00

    Hi,

    Have your used roaming profiles, FSLogix or UPD?

    You can collect a WPR (Windows Performance Recorder) trace to help you troubleshoot and diagnose your issue.

    https://community.carbonblack.com/t5/Knowledge-Base/How-to-Collect-a-WPR-Windows-Performance-Recorder-Trace/ta-p/51010

    Thanks

    Eleven

    If the Answer is helpful, please click "Accept Answer" and upvote it. Thanks.


2 additional answers

Sort by: Most helpful
  1. Anonymous
    2021-02-10T13:30:26.503+00:00

    Hello, @Kamil Langa , That used to happen with me too, but when I switched to another browser, it worked.
    I hope this answer is helpful.

    0 comments No comments

  2. Kamil Langa 21 Reputation points
    2021-02-11T08:54:25.897+00:00

    Well I managed to get about 3 minutes slowness recorded with WPR. But it started a few minutes earlier.

    What should I do with the trace ? I have no access to https://community.carbonblack.com/groups/cb-vault even after registration.