Can't delete desktop icon (xxx.Ink) in user profile by GPO

youki 1,016 Reputation points
2021-02-10T16:23:41.823+00:00

Hello,
it doesn't work.
Defined a GPO as described here:
https://community.spiceworks.com/topic/1985919-why-isn-t-my-gpo-to-delete-two-specific-desktop-shortcuts-working

"In order to delete the desktop shortcut that's stored in username/desktop, I had to create a user GPO (User Configuration --> Preferences --> Windows Settings --> Files) to delete the file %DesktopDir%\file.lnk"

I also tried a gpo for a shortcut, URL, folder, that's weird.

It works, if i want to delete a shortcut of the public desktop by "computer configuration".

PS: Would be great, if i don't have to write a script.

Regards

Windows
Windows
A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.
4,952 questions
0 comments No comments
{count} votes

Accepted answer
  1. youki 1,016 Reputation points
    2021-02-11T10:13:03.21+00:00

    Hi,
    I found out that it was only a local profile. So i defined the full path and it's working now.
    Was very laborious to find it out because it based on an old VB script that was removed and the icon was on unknown machines (double icon with different path by different creation).
    Thank you for the support.

    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. Fan Fan 15,306 Reputation points Microsoft Vendor
    2021-02-11T03:24:52.98+00:00

    Hi,

    Based on the situation you mentioned, any possible the users don't have the permission to do this?
    Any events logged in the event viewer?
    If not ,i would recommend you use the enable the GPSVC log , and run the gpupdate /force to check more details for why the user configuration was failed.
    For your reference:
    https://blogs.technet.microsoft.com/askds/2015/04/17/a-treatise-on-group-policy-troubleshootingnow-with-gpsvc-log-analysis/

    Best Regards,

    0 comments No comments