Updated way to export from Azure?

Rick Elder 21 Reputation points
2021-02-10T18:20:50.287+00:00

I am trying to export the disks from Azure.
I was trying to follow:
https://learn.microsoft.com/en-us/azure/virtual-machines/windows/download-vhd

But the section of generating the download URL does not seem to be correct anymore. The whole Disk Export function on the left does show up.

It shows the VHD URI... however if you actually try to launch it, it says there is no file there. Which makes sense since I did not actually export it yet, but there is no option to do it.

Is there a new section to export, or is something just not working right?

Thanks in advance!

66598-screenshot-2021-02-10-130748.png

Azure Disk Storage
Azure Disk Storage
A high-performance, durable block storage designed to be used with Azure Virtual Machines and Azure VMware Solution.
586 questions
0 comments No comments
{count} votes

Accepted answer
  1. deherman-MSFT 34,436 Reputation points Microsoft Employee
    2021-02-10T23:52:38.12+00:00

    @Rick Elder
    This is because you are using an unmanaged disk. If you convert the unmanaged disk to managed, this will show up as an option. To download the VHD from an unmanaged disk you can navigate to the storage account and download it from the portal or download it from Storage Explorer. The Storage Account name is the first section of the VHD URI that you have blacked out.

    Please try this out and let me know if doesn't resolve your issue or you have further questions.

    -------------------------------

    Please don’t forget to "Accept the answer" and “up-vote” wherever the information provided helps you, this can be beneficial to other community members.

    0 comments No comments

2 additional answers

Sort by: Most helpful
  1. Rick Elder 21 Reputation points
    2021-02-11T13:47:21.733+00:00

    Awesome. I am glad its that easy. Ill give that a go shortly and verify. Thank you!

    0 comments No comments

  2. Rick Elder 21 Reputation points
    2021-02-16T18:47:23.89+00:00

    Thank you, yes that did seem to do the trick.

    0 comments No comments