Ex2010 AD2016

Michael Rhodes 1 Reputation point
2021-02-10T21:39:40.587+00:00

Trying to help a small client with their Exchange environment.
Exchange 2010 SP1 RU8
Win2016 AD servers
Domain and Forest functional levels are at 2016.
The compatibility matrix isn't entirely clear about AD/Server OS levels. It seems clear that the DFL/FFL need to be lower, but is having 2016 AD servers an issue as well? Could I lower the DFL/FFL to get SP3 RU22 or higher installed or is having 2016 DC's going to still be an issue?
The client will eventually move to O365, but it's my understanding they need to get Exchange upgraded first.

Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,445 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Andy David - MVP 143.8K Reputation points MVP
    2021-02-10T21:49:21.943+00:00

    Yea thats not supported from the matrix you referenced:
    https://learn.microsoft.com/en-us/Exchange/plan-and-deploy/supportability-matrix?view=exchserver-2019

    So the question is will it work? Maybe... Not supported often means, "not tested". - and if something goes wrong, you will be told by support that its "not supported" :)

    Personally, I would plow ahead. Now, you can rollback the DFL/FFL, sure, but that has its own risks as well...

    The big thing is to get Exchange 2010 to SP3 plus the latest RU so you can run the Hybrid Wizard and move those mailboxes to 365.
    You may run into errors when you run the Exch Upgrades or it may stop you, but then you at least know what you need to do and can plan B it.

    66560-image.png