SSRS Database Configuration Errors

Brandie Tarvin 1 Reputation point

We are trying to upgrade SQL & SSRS from 2012 to 2019. While we were able to restore the 2012 ReportServer and ReportServerTempDB to the new 2019 instance and point SSRS 2019 to them, we can't seem to open them. So we decided to create new SSRS databases by uninstalling SSRS 2019, removing the restored databases, and create new databases through RS Configuration Manager.

Now we're getting the error in the attached picture. SSRS simply will not create a new database no matter what we tried. I've googled the error but keep coming up with links for SQL 2005 through 2016. Someone on SSC found a link to a 2017 issue that sounds like mine, but the solution was for Microsoft to fix the installer program and the user had to re-download it after the fix and upgrade which apparently worked.

This is a non-production server, Windows Server 2016 Standard 64 bit, and we're trying to install Developer edition of SSRS.67028-ssrs-2019-install-error.png Does anyone have any thoughts on how we can get SSRS to create the new database so we can import our reports?

SQL Server Reporting Services
SQL Server Reporting Services
A SQL Server technology that supports the creation, management, and delivery of both traditional, paper-oriented reports and interactive, web-based reports.
2,631 questions
0 comments No comments
{count} votes

6 answers

Sort by: Most helpful
  1. Joyzhao-MSFT 15,536 Reputation points

    Hi @Brandie Tarvin ,
    I cannot open the picture you attached smoothly.
    Do you have any error information you can provide? For now, I think the best way is to reinstall.
    It is worth mentioning that when we update, we not only need to back up the database, but also the encryption key.
    It is a good choice to check the error log or pay attention to the error message at any time. Usually it will give us a hint.
    Best Regards,

    If the answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. Brandie Tarvin 1 Reputation point

    Reinstallation doesn't work. We've tried it, multiple members of my team, at least 6 times total, including reboots between uninstall and install.

    The picture error is as follows:

    *Report Server Configuration Exception

    Exception Details:

    Microsoft.ReportingServices.WmiProvider.WMIProviderException: An error occurred when attempting to connect to the report server remote procedure call (RPC) end point. Verify that the Report Server Windows service is running, and then retry the operation. -->

    System.Runtime.InteropServices.COMExecption: The RPC server is not listening. (Exception from HRESULT: 0X800706B3)

    -- End of inner exception stack trace --

    at Microsoft.ReportingServices.WmiProvider.RSWmiAdmin.ThrowOnError

    (ManagementBaseObject mo)

    at Microsoft.ReportingServices.WmiProvider.RSWmiAdmin.GenerateDatabaseScript(StringdatabaseName, Int32 lcid, Boolean isSharePointIntegrated, String& script)

    at ReportServicesConfigUI.WMIProvider.RSReportServerAdmin.GenerateDatabaseScript(String databaseName, Int32 lcid, Boolean isSharePOintIntegrated, String& script)*

    Regarding the encryption key bit, I know how to do that but for some reason we're unable to back up the encryption keys on our old servers via Config Manager or via other methods (powershell, command line). Since we can't get the encryption keys for the old databases, my next thought was to try creating a new SSRS database to start from scratch. That's where I'm getting the above error. I can't even create a blank / new database.

    Any other thoughts?

    0 comments No comments

  3. Joyzhao-MSFT 15,536 Reputation points

    Hi @Brandie Tarvin ,
    Try the following:
    1.Re-download SSRS 2019
    2.Run the installer and choose "Upgrade Reporting Services."
    3.Run Report Server Configuration Manager and you should be able to configure your report server.

    If this method does not work, please run this in a command line with elevated privileges: **netsh http add iplisten***IPAddress*.
    Then re-ran Report Server Configuration Manager and create the database.
    Note: The IP address must exist on the local computer.

    Hope this helps.
    Best Regards,

    If the answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  4. Brandie Tarvin 1 Reputation point

    I've done this before per instructions from a thread I found regarding SQL 2017. But per your instructions, I downloaded the installer a third time, ran it, clicked Upgrade, changed the edition to SQL Developer, and the NEXT button is greyed out. It won't give me the opportunity to upgrade SSRS.

    So I tried the next step of your instructions, the netsh, and I get the same error I originally posted about.

    Any other suggestions?

    0 comments No comments

  5. Brandie Tarvin 1 Reputation point

    Someone on mentioned the problem could be a version mismatch. We've upgraded SQL 2019 to CU 8. Would that cause an issue with SSRS RTM being able to be installed properly?

    0 comments No comments