UEFI doesn't boot but BIOS does with SCCM PXE

RostKost 6 Reputation points

I'm having trouble to EFI Network boot.

My setup is simple SCCM with native “ConfigMgr PXE Responder Service” and separate server for DHCP without options like 67/68/69.
All test clients in same broadcast domain, so IP helper is not necessary needed.

If client use old-school BIOS, it can boot. If it use UEFI, PXE network boot doesn't work.

I can see communication between the client and SCCM/PXE server using the wireshark sniffer. So, client got IP address from DHCP server and PXE settings from SCCM/PXE server. But it doesn't start TFTP request.

I tried to use different type of client with different firmware. It was HP laptops G3/G5/G7 and vmware virtual machine and Lenovo laptop. The results were the same, client didn't ask TFTP request in case of UEFI firmware.
Additional info I got from laptop (see the screenshot) PXE-E99 unexpected network error.

I checked SMSPXE.log and can see replay confirmation from the SCCM DP/PXE server to the client with
BootFile: smsboot\x64\wdsmgfw.efi

I got this file in 1 second from another machine with the command

tftp -i GET smsboot\x64\wdsmgfw.efi


I tried to use the WDS service instead of SCCM PXE; change vNIC for virtual machine (e1000 and vmxnet 3); change wdsmgfw.efi file to another version from SCCM; change TFTP block size (512/1024/1456/8192/16384); tried to boot from different hardware with EFI firmware, like HP / Lenovo ; tried to setup DP outside of vmware infrastructure, on physical hardware ...

The version of SCCM (2002) and Win ADK ( 10.1.19041.1) and Win ADK PE ( 10.1.19041.1)

And finally, I have no idea anymore. Any Help is appreciated :) !


Microsoft Configuration Manager
{count} vote

3 answers

Sort by: Most helpful
  1. Fiona Yan-MSFT 2,311 Reputation points


    Thank you for posting in Microsoft Q&A forum.

    Separate server for DHCP without options like 67/68/69.

    To prevent misunderstanding, could you please share one DHCP server option screen shoot?

    All test clients in same broadcast domain, so IP helper is not necessary needed.

    Based on my understanding, If the SCCM clients, DHCP server and the PXE-enabled DP are set the same subnet, we don't need the IP helper.

    Based on a lot of research, many situations may cause this issue. Could we know if the boot images were distributed to our DP successfully?
    We could check the image status like the image below:

    Have a nice day!

    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. rickvbr 1 Reputation point

    Hi @RostKost

    Have you found the result of your issues ? i'm experiencing the same pb with gen 2 Hyper-V VM. Did the upper steps but without any success. tks

    0 comments No comments