Azure Storage Explorer incorrect prerequisites and forces me to restart pc to clear errors

Graeme W 1 Reputation point
2019-12-09T11:41:55.94+00:00

I've had Azure Storage Explorer installed. According to the below page "For all versions of Windows, Storage Explorer requires .NET Framework 4.6.2 or later."
https://learn.microsoft.com/en-us/azure/vs-azure-tools-storage-manage-with-storage-explorer?tabs=windows#prerequisites

I have .net framework 4.7.1. However when I try to run the Storage Explorer it spawns multiple error messages telling me that 4.7.2 is required. In fact the only way I can stop the messages appearing is to restart the pc

There doesn’t seem to be any option to configure the app to use a different .net version so looks like the only option is to install 4.7.2. However this is a pain as I need to get IT dept. to install for me

Can I ask Microsoft
1 – Correct the online prerequisite information
2 – Get the app to handle this kind of issue tidily without me having to restart the pc

Cheersalt text

Azure Storage Explorer
Azure Storage Explorer
An Azure tool that is used to manage cloud storage resources on Windows, macOS, and Linux.
148 questions
No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Vaibhav Chaudhari 37,756 Reputation points
    2019-12-09T12:15:23.01+00:00

    Is this the latest 1.11.1 version? Please see if suggestions given in below helps:

    Windows: v1.11.1 can't be launched saying .NET 4.6.2 isn't installed

    Also, this forum is not suitable for this question, please raise it on Azure storage forum.

    No comments

  2. ASHLEY NEWCHURCH 1 Reputation point
    2019-12-16T03:34:26.36+00:00

    can you get me on the net

    No comments