Newly converted Windows server 2012 isn't updating

Sudz28 186 Reputation points

Just last week I took a Windows Server 2008 VM server and did an in-place upgrade to Windows Server 2012 R2. The upgrade seemed to go off without a hitch. Now that it's properly showing as a 2012 server though, I can't get it to update. I have an enclave environment with our own WSUS server, and the WSUS server shows it now in the correct 2012 server group and shows it checking in. It shows that this server has 213 updates waiting for it (no surprise). However, when I run Windows Update on the newly converter server it always returns "no updates".

I checked the CBS.log file on the offending server and it seems to have entries for a bunch of updates, but says things like "No Parent found, go absent". Checking for the term 'fail', I also see messages like:
"Failed to start upload with file pattern: c:\windows\servicing\sqm*_std.sqm, flags: 0x2 [HRESULTS = 0x9000400 - E_FAIL ]"
"Failed to start standard sample upload"
"Failed to upload all unsent reports"
"Failed to internally open package [HRESULT = 0x800f0805 - CBS_E_INVALID_PACKAGE]"
"Failed to OpenPackage using worker session"

I can't tell if any of these kinds of messages are true 'failure' messages or not, but I find it odd that when I run Windows Update it doesn't come back and say that it Failed, it just comes back and says there aren't any updates... which is clearly not the case?

Windows Server 2012
Windows Server 2012
A Microsoft server operating system that supports enterprise-level management, data storage, applications, and communications.
1,462 questions
Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
11,116 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Dave Patrick 416.3K Reputation points MVP

    In-place upgrades are never recommended for a number of reasons.

    If your installation media was a gold or RTM version then you'll need to install this set as a prerequisite. When 2012 R2 RTM'd the updates were called rollups and were not cumulative and they also had to be installed sequentially in correct order.

    then at this point; or if you installed Windows Server 2012 R2 with Update then you can start using the cumulative updates here.
    the latest SSU

    followed by the latest Monthly Rollup
    The latest always contains new fixes plus the previous monthly update.

    --please don't forget to Accept as answer if the reply is helpful--

  2. Sudz28 186 Reputation points

    Regardless of the actual cause of the issue, I was able to get it working again by executing the following commands on the server from an elevated command prompt:
    sc config wuauserv start= disabled
    sc stop wuauserv
    ren %windir%\softwaredistribution softwaredistribution.old
    sc config wuauserv start= auto
    sc start wuauserv

    After this, I rebooted and then it finally showed that it correctly had over 200 updates (2012 updates) to work through. Issue resolved!

    0 comments No comments