Cannot register Application ID URI api://{instance}{client_id}

Larry Lau 116 Reputation points

I am establishing integration between our Microsoft Teams instance and our ServiceNow instance. One of the step is to register a single-tenant application in our Azure AD with Application ID URI in the following format api://{instance}{client_id}

However, I keep getting the following error message:
Failed to update application property. Error detail: The host name should not be based on already owned domain paramName.

ServiceNow is a SaaS application hosted by ServiceNow at {our_instance} so I don't own the domain and I can't add this domain as a custom domain in our Azure AD tenant. I can't change where it is hosted either.

MS Teams expects the Application ID URI in the above format in order for SSO to work. As they use this value to ensure your request is coming from the same domain.

I contacted ServiceNow technical support and was told to contact Azure support. I am not sure who is responsible to make this work. Any suggestion what I can try?

Microsoft Teams Development
Microsoft Teams Development
Microsoft Teams: A Microsoft customizable chat-based workspace.Development: The process of researching, productizing, and refining new or existing technologies.
2,540 questions
Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
17,577 questions
{count} votes

Accepted answer
  1. Larry Lau 116 Reputation points

    Turn out that the Azure AD team has rolled out additional logic recently. The workaround is to use https:// instead of API://

    So your Application ID URI should have this format https://{instance}{client_id}

    You will use this as your Client ID to match accordingly in ServiceNow.

4 additional answers

Sort by: Most helpful
  1. Rama-MSFT 176 Reputation points

    Hi anonymous user-lau,

    Currently using Domain as * is not supported. Could you please check this docs for more info. Also check the below screen shot.


  2. Adrian Herdan 1 Reputation point

    I am experiencing the exact same issue with a customer. We originally were able to set it up on our own tenant 3 weeks ago, then about 2 weeks ago we got the same issue when doing the setup for a customer, tried doing it again on our own instance and got the same error. Is there any solution for this?

    0 comments No comments

  3. Adrian Herdan 1 Reputation point

    Thank you Larry! Much appreciated! I was able to setup the HUB.

  4. Shivaji Varma 1 Reputation point

    Can you please retire this article? As issue is now fixed.

    0 comments No comments