Strange access to external hard drive

Jean-Paul MOLINA 1 Reputation point
2020-05-16T11:39:20.787+00:00

Hi everybody,
I have got a strange issue with my Intenso External 3.0 SCSI Disk Device (5TB) which has its own power supply.
It is plugged in a 3.1 USB socket.

  • File explorer sends an error message --- Location not available
  • diskmgmt tells the HD is safe and displays the files system when Exploring (right click Explore)

So I do not understand this behavior. How to fix it up ?
All drivers have been checked out ( external drive and usb controlers )
Any help should be appreciated. Thanks.

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
37,537 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Leon Laude 85,716 Reputation points
    2020-05-16T11:46:33.203+00:00

    Hi,

    Have you had a look at the Frequently Asked Questions (FAQ)? for the "Hard drives" section?
    https://www.intenso.de/en/support/faq

    From the above link:

    Why does the hard drive not show a function, resp. the LED does not light?

    Connect, if available, both connections of the supplied Y-USB cable, to ensure adequate power supply. With external 3.5” hard drives please check whether the supplied power pack is properly connected to the socket and hard drive and whether you have pressed the On/Off key of the hard drive.
    To exclude a defective USB slot as error source, plug the external hard drive into a different USB port. If this procedure does not lead to success, please check the functionality of the external hard drive on another PC. If the external hard drive works on this other PC, there is a configuration or hardware problem on the first PC. In this case please download all updates for your operating system and check whether a firmware update is available for your mainboard.
    If the external hard drive does not function on the second computer either, there is most likely a defect on the external hard drive. In this case please contact your dealer and carry out a complaint.
    If you have connected the hard drive via a USB hub, please check in any case whether the USB hub is correctly connected to the power pack to guarantee a proper power supply.

    Best regards,
    Leon