outlook 2019 takes long time to open

Lucas Vorms 251 Reputation points

Dear all,

We are testing office 2019 and saw that it is taking very long time to launch.

If we use chronometer we observed that it takes 29 second to launch outlook 2019.

if we modify the host file as below : outlook.office365.com

Then it takes 7 seconds to launch.

As we don't want to modify the host file of all the computers is there any ways to just disable the office 365 from GPO or something else ?
FYI We are using Exchange 2016.



Office Management
Office Management
Office: A suite of Microsoft productivity software that supports common business tasks, including word processing, email, presentations, and data management and analysis.Management: The act or process of organizing, handling, directing or controlling something.
1,856 questions
Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,027 questions
0 comments No comments
{count} votes

5 answers

Sort by: Most helpful
  1. Ashok M 6,491 Reputation points

    Hi @Lucas Vorms ,

    You can disable the Autodiscover query to Office365 using the registry key.

    Create a DWORD value for ExcludeExplicitO365Endpoint and change the value to "1":
    RegKey: ExcludeExplicitO365Endpoint
    Value: 1

    You can create GPO to create this registry and push it to the client machines


    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    If the above suggestion helps, please click on "Accept Answer" and upvote it.

    0 comments No comments

  2. Yuki Sun-MSFT 37,376 Reputation points

    Hi @Lucas Vorms ,

    To add to what AshokM mentioned, this can also be controlled by the built-in policy below (Administrative Template files can be downloaded via this link. ):


    After the above policy is applied, the following registry key will be created accordingly:

    If the above doesn't work, please select "Disable the Autodiscover V2 service" as well in the group policy and check if there could be any improvement:

    The registry key will be changed to as follows:

    If an Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  3. Lucas Vorms 251 Reputation points

    Thanks a lot for your answers.

    We tested but it didn't decrease the launch time as much as when we edited the host file.

    It is still taking 25 second to launch outlook 2019.


  4. Lucas Vorms 251 Reputation points

    Dear YukiSun,

    Thank you for your reply.

    Unfortunately it is still taking long time to launch.
    Please find below the screenshot of my registry settings.


  5. Stefan Falk 161 Reputation points

    Hello everybody,

    I wanted to conduct the connectivity test in English language. So I went to https://testconnectivity.microsoft.com/tests/exchange, choose the settings in the top right corner, choose English language and clicked save. However, nothing happened. The language dialog sayed open, and the language did not change. I tested this from my own workstation with the same results. Why can't I save that language choice?

    We implemented a policy setting HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\AutoDiscover\ExcludeExplicitO365Endpoint to a DWORD = 1 long ago, but it does not seem to help here.