File system task error ; Access to the path " " is denied when copy file using file system task

bstar_ 61 Reputation points

I am using file system task to copy files from one folder to another folder.
When i tried to copy fileA from folderA to folderB, an access denied to path error will pop up when folderB has fileA.

I tried deleting fileA in folderB and run my SSIS flow, the fileA is able to copy successfully from folderB to folderA.

I have set overwrite destination to Truev and have all permission (read and write) but still having the error when the file is already existed in the folder .

Anyone know how to solve this issue?

SQL Server Integration Services
SQL Server Integration Services
A Microsoft platform for building enterprise-level data integration and data transformations solutions.
2,311 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. EchoLiu-MSFT 14,561 Reputation points

    Hi @bstar_

    Please try when Running package SSISDB:

    1. SQL Server Accounts Permissions
      Add Read & Write permissions to the The account you are logged in on the specified paths
    2. Add a windows authentication to the Network account

    If you have any question, please feel free to let me know.


    If the answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. bstar_ 61 Reputation points

    Hi @EchoLiu-MSFT ,
    Thanks for helping!

    1. My ssis package is not connected to any SQL Server Accounts
    2. I have checked the permission for my account. i have both read and write access
    3. I am using VM to host VS with SSIS to run the packages.
    0 comments No comments