Can someone help me fix this BGInfo error?

Domantas Orentas | FITSOUT 21 Reputation points
2021-02-17T14:49:38.397+00:00

Hello, I'm having a problem. I'm the IT specialist of a company. Then a host turns on a computer it gets an error message "Cannot find the configuration file 'C:\BGInfo\bginfo2.bgi/SILENT.bgi' do you want to create a new file". And when I press YES, I get another error message "Error loading 'C:\BGInfo\bginfo2.bgi/SILENT.bgi'. And this message always pops-up when a host turns on the computer. I'm new this job and in this field, so I have little knowledge what to do here. Can someone help me?

Sysinternals
Sysinternals
Advanced system utilities to manage, troubleshoot, and diagnose Windows and Linux systems and applications.
1,114 questions
{count} votes

Accepted answer
  1. Michael Taylor 50,106 Reputation points
    2021-02-17T14:59:04.317+00:00

    Most likely a permissions issue although the path looks odd as well. BGInfo stores the configuration you set up in a .bgi file. You can create your own but it defaults to default.bgi IIRC. However in this case it is using a custom file. Most likely somebody set up a startup task or dragged a shortcut to BGInfo into the Startup folder and it starts up automatically on login. However it cannot find the file and is generating the error. When you try to create the file it is attempting to write to the BGInfo\bginfo2.bgi folder and fails, most likely because of the bad path or permissions.

    1. Go to the Startup folder and look and see if there is a shortcut to BGInfo there. If not then go look in Task Scheduler instead.
    2. Look in the file system. There is most likely a BGInfo folder. However the bginfo2.bgi folder looks wrong. I suspect you have a bginfo2.bgi file instead.
    3. Adjust the shortcut (or task) to use the correct bgi file. It should configured to specify the path to the bgi file to load at startup.
    4. If neither file exists then start BGInfo as an admin. Adjust the display settings to your liking and then save the file as silent.bgi. Fix the path that the shortcut is using as mentioned earlier.

0 additional answers

Sort by: Most helpful