The requested size for resource is currently not available in location westus2 zones ''

Maria Del Carmen Jimenez Campos 21 Reputation points
2021-02-17T15:30:41.313+00:00

We have a working arm template that was deploying VMs successfully using Standard_D4ds_v4 vm sizes in west us2. Today I'm getting errors trying to deploy new VMs, and the error says the size is not available in the region.

I've done some checks and the size is available in the region and for the subscription. If I look into the usage we have plenty of cpus avaible (only using 4 of 200 at the moment)

Also, to double check I've tried with other sizes, and I managed to create a VM with Standard_F16s_v2 ...

Is something happening in the Azure side that is not allowing us to create VMs with that size in west us 2?

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
7,360 questions
{count} votes

Accepted answer
  1. shiva patpi 13,156 Reputation points Microsoft Employee
    2021-02-17T23:56:58.92+00:00

    Hello @Maria Del Carmen Jimenez Campos ,
    Thanks for your query.

    I just tried deploying the same SKU in WestUS2 region and it went through successfully.
    Can you kindly try out now from your end - It should go through fine.

    Let us know if you have additional questions !


0 additional answers

Sort by: Most helpful