Cannot access container in a Storage account

aliasmrchips 26 Reputation points
2021-02-17T15:09:40.773+00:00

I am trying to follow this quickstart: https://learn.microsoft.com/en-us/azure/storage/blobs/storage-quickstart-blobs-portal

However, after creating the container, I can't navigate to it in order to upload a blob.

In particular, I get an error saying "This request is not authorized to perform this operation."

Azure Blob Storage
Azure Blob Storage
An Azure service that stores unstructured data in the cloud as blobs.
2,542 questions
{count} vote

Accepted answer
  1. shiva patpi 13,156 Reputation points Microsoft Employee
    2021-02-18T04:13:42.493+00:00

    Hello @aliasmrchips ,
    Just to confirm your issue was due to the Firewall of the storage account.

    On the Azure Portal you saw for your storage account Firewall was enabled.
    (Storage Account -> Networking -> Allow Access from "Selected Networks")

    To resolve the issue: You have selected "All Networks".

    I just summarized here in the answer section , so that you can "Accept this answer" it will help community out there .

    2 people found this answer helpful.

3 additional answers

Sort by: Most helpful
  1. shiva patpi 13,156 Reputation points Microsoft Employee
    2021-02-17T23:44:50.127+00:00

    Hello @aliasmrchips ,
    Thanks for your query , some times this might happen due to in-sufficient privileges'

    Can you try adding below role for that storage account ?

    Steps:

    1. Browse to Storage Account in the Azure Portal
    2. Access Control (IAM)
    3. Grant Access to this resource section (Add Role Assignments)
    4. Role: Storage Blob Data Contributor
      Assign Access to: Use the default values (I.e. User , Group , or Service Principal)
      Select: User Name
    5. Save

    Kindly let us know if those steps help you out in resolving the issue and don't forget to "Accept the Answer".

    1 person found this answer helpful.

  2. Melo, Carmo 6 Reputation points
    2023-02-16T18:30:25.29+00:00

    add the storage direct "Reader" for that user

    1 person found this answer helpful.

  3. aliasmrchips 26 Reputation points
    2021-02-18T00:35:25.977+00:00

    I am the owner, which seems like it should be sufficient. I tried adding myself to the container, to the storage account and to the subscription as a Contributor and a Storage Blob Data Contributor, all to no effect. I also tried logging out and back in and using the Microsoft Azure Storage Explorer application.