Disk issue in Azure

Erwin 21 Reputation points
2021-02-17T15:23:41.79+00:00

I have a weird bug. I manually deleted my resource group so the disk within that resource group got deleted. But when I tried to deploy again with Terraform, it complained the disk was already present.

I checked the portal and could not see the disk. But when started up the cli, and asked a list for every disk in that resource group, the disk is there and is unattached.

So, I tried to delete it in the cli, it succeeds but it is still there. It is unremovable...

What can I do?

Azure Disk Storage
Azure Disk Storage
A high-performance, durable block storage designed to be used with Azure Virtual Machines and Azure VMware Solution.
586 questions
0 comments No comments
{count} votes

Accepted answer
  1. Sumarigo-MSFT 44,501 Reputation points Microsoft Employee
    2021-02-18T13:13:25.577+00:00

    @Erwin If you are still able to list disk try to delete using the script mentioned in the below article and It may take some time or necessary changes to take place.

    Refer to this article and try to delete using the Powershell script

    If the issue still persist, we need perform deeper investigation, I would recommend you to contact support, so If you have a support plan, I request you file a support ticket, else please do let us know, we will try and help you get a one-time free technical support. In this case, could you send an email to AzCommunity[at]Microsoft[dot]com referencing this thread as well as your subscription ID. Please mention "ATTN subm" in the subject field. Thank you for your cooperation on this matter and look forward to your reply.

    Hope this helps!

    Kindly let us know if the above helps or you need further assistance on this issue.

    ---------------------------------------------------------------------------------------------------------------------------

    Please don’t forget to "Accept the answer” and “up-vote” wherever the information provided helps you, this can be beneficial to other community members.

    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. Erwin 21 Reputation points
    2021-02-19T07:41:47.02+00:00

    Hello,

    I tried a lot of things, including part of that script. After some time, all of a sudden, portal showed the disk! Out of the blue, and I could delete it... I hadn't answered on this thread yet to see what the reply would be but it is fixed. Not certain if it is because of something I did but I can continue now.

    Note: Disk had not been showing for hours so it is not a "I didn't have any patience" situation.

    Thank you for the help!

    0 comments No comments