VM Connect Enhanced Session

AMIM 26 Reputation points
2021-02-18T18:39:37.683+00:00

I have hyper-v on windows 2016 server.

Whenever I use the enhanced session when connecting to a VM using the "connect" option in hyper-v manager the ctr-alt-del option is greyed out and unusable. If I switch to a basic session it becomes available again.

What is the reason for this behaviour and how to fix it?

Hyper-V
Hyper-V
A Windows technology providing a hypervisor-based virtualization solution enabling customers to consolidate workloads onto a single server.
2,597 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Xiaowei He 9,876 Reputation points
    2021-02-19T02:07:33.133+00:00

    Hi,

    It seems to be designed behavior, when I'm in enhanced session mode, the "ctr+alt+del" is also grep out, when in basic mode, the crt+alt+del is available:

    69851-image.png

    69861-image.png

    Thanks for your time!
    Best Regards,
    Anne

    -----------------------------

    If the Answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. AMIM 26 Reputation points
    2021-02-19T20:30:47.907+00:00

    So you are saying there is no way to fix this? But I don't get what is the point of this if it is indeed designed behaviour??

    One doesn't only need to use ctrl-alt-del for login. Sometimes one needs to use it for other reasons and this would require switching to basic session. Lot of trouble for no reason at all.

    0 comments No comments

  3. Xiaowei He 9,876 Reputation points
    2021-02-26T07:13:50.733+00:00

    Hi,

    As far as I'm concerned, the crtl+alt+delete isn't available in enhanced session mode may due to the enhanced session mode is RDP connect.

    For more information, you may try to the feedback hub to feedback this issue:

    https://windowsserver.uservoice.com/forums/295047-general-feedback
    Thanks for your time!
    Best Regards,
    Anne

    -----------------------------

    If the Answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments