SP2013 Office 2016: New Document requires a Sharepoint Foundation-compatible application and web browser

Khushi Shaikh 86 Reputation points

Hello SP Gurus - We have SP 2013 Server, Office 2016 and Windows 10 users. The New Document functions properly on IE. As recommended not to use IE, we are using Microsoft Edge or Chrome. In both Edge and Chrome, we are facing error "'New Document' requires a SharePoint Foundation-compatible application and web browser. To add a document to this document library. Click the 'Upload Document' button." I have gone through all the old threads and nothing helped.

Any guidance please?

Thanks & Regards,

SharePoint Server Management
SharePoint Server Management
SharePoint Server: A family of Microsoft on-premises document management and storage systems.Management: The act or process of organizing, handling, directing or controlling something.
2,862 questions
0 comments No comments
{count} votes

Accepted answer
  1. JoyZ 18,051 Reputation points

    Hi @Khushi Shaikh ,

    What's your build version of SharePoint server?

    Per my test,If the build version is eariler such as 15.0.4569.1506, I could reproduce your issue.

    In another test environment, the SharePoint build version is 15.0.4989.1001, which works well without any error, we could add a new document both in Chrome and Edge.

    We suggest you install a newer CU if your version is too old, then compare the result.

    I install the latest CU from here, then I could add a new document in chrome and edge, as shown below:



    If an Answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    1 person found this answer helpful.

1 additional answer

Sort by: Most helpful
  1. Khushi Shaikh 86 Reputation points

    Thanks @JulieWang-MSFT I really appreciate your guidance. After February 2021 CU Updates, it is working all good now.

    Best Regards,

    0 comments No comments